J'utilisais jusqu'à maintenant TeX Live 2017 sous Windows et tout fonctionnait bien. J'ai voulu installer TeX Live 2022 et l'installation s'est déroulée sans problème. Le seul souci maintenant c'est que je n'arrive plus à compiler les fichiers qui ont des noms accentués, alors que ça marchait parfaitement avec TeX Live 2017. Si je fais un test avec un fichier dont le nom ne comporte pas d'accent, aucun problème.

Par exemple, j'écris dans la ligne de commande :

pdflatex éssès.tex

Et voilà le message d'erreur :

This is pdfTeX, Version 3.141592653-2.6-1.40.24 (TeX Live 2022) (preloaded format=pdflatex) restricted \write18 enabled.
entering extended mode
! I can't find file `'.
<to be read again>
\protect
<*> éssès.tex
(Press Enter to retry, or Control-Z to exit)
Please type another input file name:

Posée 29 Aoû '22, 18:12

OJANIN's gravatar image

OJANIN
111
Taux d'acceptation : 0%

Modifiée 29 Aoû '22, 19:02

denis's gravatar image

denis ♦♦
6.2k1510

Bienvenue sur TeXnique.fr !

(29 Aoû '22, 18:30) denis ♦♦ denis's gravatar image

Les formules de politesse et les signatures sont à éviter : celle(s) de votre contribution a (ont) été supprimée(s).

(29 Aoû '22, 18:31) denis ♦♦ denis's gravatar image

Je sais que ça ne va pas vous consoler, mais je ne rencontre pas ce problème sous GNU/Linux.

(29 Aoû '22, 18:37) denis ♦♦ denis's gravatar image

Cela fonctionne-t-il avec des double-quotes : pdflatex "éssès.tex" ?

(29 Aoû '22, 18:39) denis ♦♦ denis's gravatar image

Ca ne marche pas non plus avec les double-quotes, même message d'erreur

(29 Aoû '22, 21:10) OJANIN OJANIN's gravatar image

Votre système Windows utilise-t-il l'UTF-8 comme codage d'entrée ?

(30 Aoû '22, 19:31) denis ♦♦ denis's gravatar image

Honnêtement je ne sais pas (Windows 10 64 bits) mais ce qui est certain c'est que entre le moment où tout marchait bien (TexLive 2017) et le moment où les noms accentués ont commencé à poser problème (TexLive 2022), la seule différence qu'il y a eu c'est l'installation de TexLive

(30 Aoû '22, 20:49) OJANIN OJANIN's gravatar image
1

Pour obtenir des informations sur l'encodage par défaut actuel de votre machine, vous pouvez recourir à la commande Powerhell [System.Text.Encoding]::Default.

(31 Aoû '22, 13:37) denis ♦♦ denis's gravatar image

À propos, pardonnez-moi si c'est une digression, mais il fut un temps où mes correspondants sous windows avaient des problèmes avec l'utf-8 façon microsoft, pas vraiment conforme aux spécifications. Est-ce toujours le cas en 2022? Windows est-il récent ou ancien?

(01 Sep '22, 20:29) joseph-tux joseph-tux's gravatar image

Après vérification, Windows m'annonce un encodage iso-8859-1

(02 Sep '22, 19:02) OJANIN OJANIN's gravatar image

Je sais que ce n'est pas très utile pour maintenant, mais j'ai toujours appris et pensé que c'était une mauvaise idée de mettre, dans les noms de fichier, des caractères non-ascii et autres qu' alphanumériques + le souligné, «_» et à la limite le tiret «-». Je ne pratique plus windows depuis que je suis à la retraite, mais il semblait que l'UTF8 de microsoft n'était pas rigoureusement conforme à la norme, et j'ignore où en est cette question. Je persiste à ignorer les accents dans les noms de fichiers.

(31 Oct '22, 17:34) joseph-tux joseph-tux's gravatar image
Affichage de 5 parmi 11 Afficher 6 commentaire(s) en plus

Y a-t-il du code TeX sur la ligne de commande, du genre : pdflatex \nonstopmode\input éssès.tex ?

ou bien est-ce sans code TeX sur la ligne de commande, du genre : pdflatex --nonstopmode éssès.tex

Dans le premier cas le nom du fichier fait partie du code TeX inséré dans la ligne de commande. Il sera analysé sous régime inputenc utf8, dans le second cas le nom du fichier ne passe pas par inputenc utf8.

Autre question : comment lancez vous la commande : depuis une console MSDOS (cmd.exe), ou powershell, ou depuis un IDE (qui selon toute probabilité passera la commande à cmd.exe).

Lien permanent

Publiée 31 Oct '22, 16:45

vincentb1's gravatar image

vincentb1
1774
Taux d'acceptation : 0%

Modifiée 01 Nov '22, 06:21

J'exécute depuis l'Invite de commandes de Windows 10.

Mon premier test était sans "fioritures" : uniquement pdflatex éssès.tex

J'ai essayé avec : pdflatex \nonstopmode\input éssès.tex , aucun changement (même message d'erreur)

Avec pdflatex --nonstopmode éssès.tex, pdflatex me dit qu'il ne connaît pas l'option --nonstopmode

Ce qui est bizarre c'est que tout fonctionnait bien avec TeXLive 2017, je n'ai rien changé d'autre que d'installer TeXLive 2022. Je me demande si lors de l'installation de TeXLive 2017 je n'avais pas changé un paramètre quelque part pour que les noms accentués soient pris en compte, mais impossible de m'en souvenir 5 ans plus tard...

En attendant j'évite les accents dans mes noms de fichiers mais j'avoue que ça m'embête un peu.

Lien permanent

Publiée 02 Nov '22, 23:49

OJANIN's gravatar image

OJANIN
111
Taux d'acceptation : 0%

@QJANIN, au temps pour moi, ce n'était pas --nonstopmode qu'il fallait essayer, mais --interaction=nonstopmode.

Sinon, la réponse donnée par Ulrike le 29 septembre 2018 ici https://groups.google.com/g/fr.comp.text.tex/c/gFk1FqC3Zt8/m/WWP3gEDfAAAJ à une question que j'avais posée sur le même thème est sans doute l'explication de votre problème, le cœur LaTeX a changé et charge inputenc utf8 par défaut sur le premier \input effectué, c'est pourquoi si vous êtes dans un OS (MWindows) et avec un shell dont la ligne de commande n'est pas en utf8 ça ne fonctionnera sans doute pas. Enfin ça dépend du shell que vous utilisez sous MSwindow (powershell, cmd, wsl ou msys2), je crois que msys2 est par défaut en utf-8, c'est peut-être la solution… Sinon avec cmd il y a une option /u ou un truc de ce genre qui marchotte --- j'écris qui marchotte, parce que fondammentalement cmd continue à interpréter la ligne de commande comme une suite d'octet, et donc avec cmd /u il y a des cas qui ne fonctionnent pas.

Au fait, je cause, je cause, mais est-ce que vous lancez la commande de compilation depuis un shell en ligne de commande, ou bien depuis un EDI ?

Lien permanent

Publiée 03 Nov '22, 22:54

vincentb1's gravatar image

vincentb1
1774
Taux d'acceptation : 0%

Modifiée 03 Nov '22, 23:16

Ah, en relisant attentivement votre réponse :

Mon premier test était sans "fioritures" : uniquement pdflatex éssès.tex

je m'aperçois que mon hypothèse est fausse, sans fioritures ça aurait dû marcher …

Si vraiment vous voulez des accents dans les noms de fichier, une solution est de passer le fichier par un lien symbolique, et son nom avec l'option --jobname

mklink le_lien.tex éssès.tex
pdflatex --jobname=éssès le_lien
Lien permanent

Publiée 03 Nov '22, 23:23

vincentb1's gravatar image

vincentb1
1774
Taux d'acceptation : 0%

Modifiée 03 Nov '22, 23:24

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×40
×5

Question posée : 29 Aoû '22, 18:12

Question vue : 558 fois

Dernière mise à jour : 03 Nov '22, 23:24