J'ai fait une bibliographie avec deux .bib et biblatex (voir ma question précédente).

Je souhaite afficher les références sans la mention « In: » dans les citations et avec les noms de tous les auteurs, sans troncature de type « et al. »

J'ai essayé le code suivant :

Ouvrir dans l'éditeur
\usepackage[backend=biber,style=numeric,sorting=none,url=false,doi=false,uniquename=full]{biblatex}

Résultat : un auteur par article et je n'ai pas trouvé comment supprimer le mention « In: ».

J'ai essayé d'utiliser le style IEEE, car ce style devrait me donner un format comme j'attends :

Ouvrir dans l'éditeur
\usepackage[backend=biber,style=ieee,url=false,doi=false]{biblatex}

Le résultat est conforme à mes attentes mais j'ai des erreurs de compilation que je n'arrive pas à résoudre.

J'ai finalement isolé le problème avec l'ECM suivant :

Ouvrir dans l'éditeur
\begin{filecontents}{ref.bib}
@Article{Udem2000,
  Title                    = {Absolute optical frequency measurement of the cesium ${D}_{2}$ line},
  Author                   = {Udem, Th. and Reichert, J. and H\"ansch, T. W. and Kourogi, M.},
  Year                     = {2000},
  Doi                      = {10.1103/PhysRevA.62.031801},
  Issue                    = {3},
  Month                    = {Aug},
  Pages                    = {031801},
  Url                      = {http://link.aps.org/doi/10.1103/PhysRevA.62.031801},
  Volume                   = {62},
  Journal                  = {Physical Review A},
  Numpages                 = {4},
  Publisher                = {American Physical Society}
}

\end{filecontents}

\documentclass[mainlanguage=english,hdr,version=inprogress]{yathesis}

\usepackage[utf8]{inputenc}
\usepackage[autostyle]{csquotes}
\usepackage[backend=biber,style=ieee,url=false,doi=false]{biblatex}

\addbibresource{ref.bib}

\begin{document}

 Combs produced in this manner can achieve typical bandwidths up to several THz and have proved their utility for the measurement of optical frequencies \autocite{Udem2000}.

\printbibliography

\end{document}

Posée 22 Sep '15, 23:32

frank's gravatar image

frank
13758
Taux d'acceptation : 0%

Modifiée 23 Sep '15, 23:43

denis's gravatar image

denis ♦♦
4.8k49

@frank Ceci est presque un ECM : dans la réponse que je donne ci-dessous, tu peux voir comment ton exemple aurait pu être encore plus ECMisé :) En particulier, il apparaît que le problème persiste si la classe yathesis est remplacée par une des classes standards, par exemple article.

(23 Sep '15, 22:56) denis ♦♦ denis's gravatar image

@frank Autre chose : il faut essayer de donner des titres informatifs aux questions, comme celui que j'ai mis ici en remplacement du précédent « Format de bibliographie » qui était vague. On pourra objecter que le titre actuel est long, mais cela tient au fait que la question en comportait en fait deux (voire trois si on tient compte du problème avec le style ieee). Cela conduit à une autre règle : ne poser qu'une question par... question.

(23 Sep '15, 23:46) denis ♦♦ denis's gravatar image

Comme le montre l'ECM ci-dessous, les erreurs de compilations sont indépendantes de la classe :

Ouvrir dans l'éditeur
\begin{filecontents}{ref.bib}
@Article{foo,
  Title                    = {Foo $D_{2}$ bar},
  Author                   = {Foo, Bar},
  Date                     = {2000},
  Journal                  = {Baz}
}
\end{filecontents}
%
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[backend=biber,style=ieee]{biblatex}
%
\addbibresource{ref.bib}
%
\begin{document}
\autocite{foo}.
\printbibliography
\end{document}

Il s'agit là d'un bug du package fournissant le style ieee (bug signalé à son auteur par votre serviteur). Il est à noter que ces erreurs disparaissent si les accolades à l'intérieur du mode mathématique dans le fichier .bib peuvent être supprimées, ce qui est le cas dans la question originale (${D}_{2}$$D_2$).

Sinon, s'il s'agit seulement de :

  1. supprimer la mention « In: » dans les citations ;
  2. faire figurer les noms de tous les auteurs (sans troncature de type « et al. ») ;

il suffit d'utiliser un style standard (numeric par exemple) et de recourir à :

  1. la commande \renewbibmacro{in:}{} ;
  2. à l'une ou l'autre des options maxbibnames=⟨entier⟩, maxcitenames=⟨entier⟩ et maxnames=⟨entier⟩ (la dernière fixant la même valeur aux 2 premières).

L'ECM suivant, qui recourt à la classe standard article mais serait valable également avec yathesis, met ceci en évidence :

Ouvrir dans l'éditeur
\begin{filecontents}{refnumerousauthors.bib}
@Article{foo,
  Title                    = {Foo ${D}_{2}$ bar},
  Author                   = {Foo 1, Bar and Foo 2, Bar and Foo 3, Bar and Foo 4, Bar},
  Date                     = {2000},
  Journal                  = {Baz}
}
\end{filecontents}
%
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[backend=biber,maxnames=99]{biblatex}
%
\renewbibmacro{in:}{}
\addbibresource{refnumerousauthors.bib}
%
\begin{document}
\autocite{foo}.
\printbibliography
\end{document}
Lien permanent

Publiée 23 Sep '15, 23:28

denis's gravatar image

denis ♦♦
4.8k49
Taux d'acceptation : 57%

Modifiée 24 Sep '15, 08:36

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×42
×35

Question posée : 22 Sep '15, 23:32

Question vue : 6,062 fois

Dernière mise à jour : 24 Sep '15, 08:36