J'ai de gros problèmes avec beamer :

  • il masque les guillemets, sinon les transforme en signes incompréhensibles ;
  • il affiche le délimiteur final de la commande \verb ;
  • il crée une erreur fatale dès que j'utilise \verbatim.

Voici un ECM :

Ouvrir dans l'éditeur Overleaf
\documentclass[9pt]{beamer}
\usepackage[utf8]{inputenc}
\usepackage{csquotes}
\usetheme{Warsaw} 
\title{Titre}
\author{EG
\date{16 novembre 2017}
\begin{document}
\begin{frame}
\titlepage
\end{frame}

\section{Trois erreurs bien distinctes}

\begin{frame}{Trois erreurs bien distinctes}

 Ici des «\\,guillemets\\,», bien entourés, qui n'apparaissent pas.
Or j'en aurai besoin dans des verbatim

test avec d'autres << guillemets >>. C'est pire.

Là mes problèmes avec la commande \texttt{verb}: le pipe final apparaît

 \verb| convert photo.JPG -modulate 100,0 NB.JPG |

Et mes soucis avec verbatim, qui crée une erreur fatale.
Donc avec des \% devant pour permettre la compilation.

%\begin{verbatim}
%Coucou
%\end{verbatim}

\end{frame}
\end{document}

Posée 15 Nov '17, 01:16

Eric's gravatar image

Eric
4115
Taux d'acceptation : 0%

Modifiée 15 Nov '17, 03:16

Pathe's gravatar image

Pathe ♦♦
5.4k158157

1

@Eric Les formules de politesse et les signatures sont à éviter : celle(s) de votre contribution a (ont) été supprimée(s).

(15 Nov '17, 03:16) Pathe ♦♦ Pathe's gravatar image

Pour les guillemets français, je rappelle qu'il n'y en a pas dans l'encodage par défaut (OT1). Pour les langues avec des lettres accentuées comme la plupart des langues hormis l'anglais, il faut utiliser l'encodage T1.

D'autre part les environnements de type verbatim ne fonctionnent avec beamer que si les environnements frame qui en contiennent sont chargés avec l'option [fragile]:

Ouvrir dans l'éditeur Overleaf
\documentclass[9pt]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{csquotes}
\usetheme{Warsaw}
\title{Titre}
\author{EG}
\date{16 novembre 2017}

\begin{document}

\begin{frame}
\titlepage
\end{frame}

\section{Trois erreurs bien distinctes}

\begin{frame}[fragile]{Trois erreurs bien distinctes}

Ici des «\,guillemets\,», bien entourés, qui n'apparaissent pas. Or j'en aurai besoin dans des verbatim

test avec d'autres << guillemets >>. C'est pire.

Là mes problèmes avec la commande \texttt{verb}: le pipe final apparaît

\verb| convert photo.JPG -modulate 100,0 NB.JPG |

Et mes soucis avec verbatim, qui crée une erreur fatale. Donc avec des % devant pour permettre la compilation.

\begin{verbatim} Coucou \end{verbatim}

\end{frame}

\end{document}

alt text

Lien permanent

Publiée 15 Nov '17, 01:45

Bernard's gravatar image

Bernard
3.7k15
Taux d'acceptation : 36%

Modifiée 15 Nov '17, 03:11

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×43
×5
×3
×1

Question posée : 15 Nov '17, 01:16

Question vue : 2,509 fois

Dernière mise à jour : 15 Nov '17, 03:16