2
1

J'ai un problème de compilation quand j'utilise ORGTBL, du mode mineur d'org-mode sous emacs, avec la classe beamer. Je précise que je n'ai pas de soucis avec la classe article, par exemple.

Pour avoir ma première colonne du tableau, qui est correctement exportée en LaTeX, je dois donner l'option :no-escape t à la commande SEND de ORGTBL. Cette option semble poser problème lors de la compilation du ficher .tex bien qu'elle soit dans l'environnement comment du package du même nom.

Ouvrir dans l'éditeur Overleaf
\documentclass[11pt,english,french,t,fleqn]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{comment}

\begin{document}
\begin{frame}
  \begin{table}
    % BEGIN RECEIVE ORGTBL tabJS
\begin{tabular}{lr}
$J_1^{Al}$ & 1 \\
$J_2^{1,AlAl}$ & 2 \\
$J_2^{3,AlAl}$ & 5 \\
\end{tabular}
    % END RECEIVE ORGTBL tabJS
    \caption{Caption}
  \end{table}
%\begin{comment}
% #+ORGTBL: SEND tabJS orgtbl-to-latex :no-escape t
% | $J_1^{Al}$     | 1 |
% | $J_2^{1,AlAl}$ | 2 |
% | $J_2^{3,AlAl}$ | 5 |
% \end{comment}
\end{frame}
\end{document}

Posée 07 Oct '16, 13:30

jerome%20dequeker's gravatar image

jerome dequeker
81611
Taux d'acceptation : 65%

Modifiée 06 Aoû '17, 02:03

Pathe's gravatar image

Pathe ♦♦
4.5k135123


Il y a deux remarques :

  • utilise l'option fragile : \begin{frame}[fragile]. Voir la page 127 de la documentation de la classe beamer. Cette option est à utiliser lorsque le contenu de frame est en mode non standard (changement de \catcode).
  • pas d'espace avant \end{comment}. À la première page de la documentation de l'extension « comment » on lit « The opening and closing commands should appear on a line of their own. No starting spaces, nothing after it », ce qui se traduit par les commandes d'ouverture et de fermeture (begin{comment}, end{comment}) doivent apparaître sur une ligne propre à eux. Sans espaces au départ et rien après. À noter que, dans ce cas, ceci s'applique aussi à \end{frame}.

Ouvrir dans l'éditeur Overleaf
\documentclass[11pt,english,french,t,fleqn]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{babel}
\usepackage{comment}

\begin{document}
\begin{frame}[fragile]
  \begin{table}
    % BEGIN RECEIVE ORGTBL tabJS
\begin{tabular}{lr}
$J_1^{Al}$ & 1 \\
$J_2^{1,AlAl}$ & 2 \\
$J_2^{3,AlAl}$ & 5 \\
\end{tabular}
    % END RECEIVE ORGTBL tabJS
    \caption{Caption}
  \end{table}
\begin{comment}
 #+ORGTBL: SEND tabJS orgtbl-to-latex :no-escape t
 | $J_1^{Al}$     | 1 |
 | $J_2^{1,AlAl}$ | 2 |
 | $J_2^{3,AlAl}$ | 5 |
\end{comment}
\end{frame}
\end{document}
Lien permanent

Publiée 07 Oct '16, 14:05

touhami's gravatar image

touhami
5.2k26
Taux d'acceptation : 54%

Modifiée 06 Aoû '17, 02:08

Pathe's gravatar image

Pathe ♦♦
4.5k135123

@touhami Ok pour l'option fragile qu'il fallait ajouter à l'environnement frame. Mais si mon environement comment pose problème, pourquoi je n'ai pas en de soucis avec la classe article ?

(07 Oct '16, 17:14) jerome dequeker jerome%20dequeker's gravatar image
2

@jerome dequeker J'ai remarqué qu'il y a un espace devant \end{comment} dans votre ECM ce qui pose problème indépendamment de la classe de document (vous pouvez essayer). Donc peut être ce n'est pas le cas de code utilisé avec la classe article.

(07 Oct '16, 17:37) touhami touhami's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×30
×3
×2
×1

Question posée : 07 Oct '16, 13:30

Question vue : 1,304 fois

Dernière mise à jour : 07 Oct '16, 17:37