Depuis longtemps j’ai utilisé la TeX Live du système (sous linux, Fedora), mais ensuite j’ai décidé de passer à la TeX Live officielle pour bénéficier de la nouvelle version de certains paquets, de « biber » en particulier.

Mais du coup j’ai quelques problèmes avec l’affichage bibliographique. Par exemple, pour le code que voici :

Ouvrir dans l'éditeur Overleaf
\documentclass[12pt,a4paper]{scrartcl}
\usepackage[protrusion=true]{microtype}

\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{polyglossia}
\usepackage{csquotes}

\usepackage{lipsum}

\begin{filecontents}{refer.bib}
@book{athanase_vitaAntonii,
    address = {Paris},
    annotator = {M. G. J. M. Bartelink},
    author = {{Athanase d’Alexandrie}},
    entrysubtype = {book},
    introduction = {M. G. J. M. Bartelink},
    number = {400},
    pagination = {section},
    publisher = {Éditions du Cerf},
    series = {SC},
    Shortseries = {SC},
    title = {Vie d’Antoine},
    translator = {M. G. J. M. Bartelink},
    year = {2004}
}
}
\end{filecontents}

\usepackage[style=authortitle, backend=biber, citestyle=verbose-trad3, isbn=false, citepages=omit, bibstyle = verbose]{biblatex}

\setmainlanguage{latin}

\usepackage[colorlinks=false]{hyperref}

\renewcommand{\newunitpunct}[0]{\addcomma\addspace}
\renewcommand{\mkbibnamelast}[1]{\textsc{#1}}
\renewcommand{\mkibid}[1]{\emph{#1}}

\addbibresource{refer.bib}

\title{Bricolage}
\author{Nemo}

\begin{document}
\frenchspacing
\maketitle

\tableofcontents

\section{Prima pars}
\lipsum[1]
cf.~\cite{athanase_vitaAntonii}
\section{Secunda pars}
\lipsum[2]
vide\autocite{athanase_vitaAntonii}
\printbibliography

\end{document}

Au lieu d’un résultat espéré :

Athanase d’Alexandrie, Vie d’Antoine, trans. and annot., with an introd., by M. G. J. M. Bartelink, SC 400, Paris : Éditions du Cerf, 2004.

... j’obtiens :

Athanase d’Alexandrie, Vie d’Antoine, bytranslatoraninM. G. J. M. Bartelink, SC 400, Paris : Éditions du Cerf,

Comment faut-il procéder pour corriger ?

Posée 23 Aoû '16, 21:42

Hypnos's gravatar image

Hypnos
314
Taux d'acceptation : 0%

Modifiée 05 Aoû '17, 22:39

Pathe's gravatar image

Pathe ♦♦
4.7k141132

Voulez-vous la bibliographie enb anglais ou en français ?

(23 Aoû '16, 23:30) Bernard Bernard's gravatar image

En utilisant overleaf (c'est à dire, en cliquant sur "Ouvrir dans l'éditeur" de ta question), j'obtiens le résultat espéré sans modifier le code source. Je pense donc que le problème vient de ton installation.As-tu des avertissement ou des erreurs pendant la compilation ?

(24 Aoû '16, 11:00) jerome dequeker jerome%20dequeker's gravatar image

@jerome dequeker A noter que la version de biblatex sur overleaf est 3.0 datée 2015/04/19 la version actuelle est 3.4 2016/05/14.

(24 Aoû '16, 12:15) touhami touhami's gravatar image

Je n’ai pas eu de problèmes avec l’installation. J’ai essayé de compiler le code source en ligne de commande et le processus se déroule bien, avec le même résultat malheureusement. Le fichier log indique un avertissement :

Bibliography string 'bytranslatoranin' undefined(biblatex) at entry 'athanase_vitaAntonii'.

Quant a la langue de la bibliographie, j’aurais préféré le français vu que le livre en question est en français, mais le texte principal n’est pas en français, alors je ne me casse pas la tête pour l’instant.

(24 Aoû '16, 17:21) Hypnos Hypnos's gravatar image

@Hypnos Quelles sont les versions de LaTeX et de biblatex installées ?

(24 Aoû '16, 18:03) jerome dequeker jerome%20dequeker's gravatar image

Si la langue principale est bien l'anglais, on peut obtenir des références bibliographiques dans la langue de l'ouvrage avec le champ Langid, en rajoutant l'option autolang=other (il faut évidemment avoir chargé babel ou polyglossia).

Maintenant, si la langue principal est le latin, ce pourrait être amusant de traduire les principaux termes pour un fichier latin.lbx. On pourrait demander de l'aide au Vatican…

Voici une démo, en rajoutant une référence anglo-saxonne qui n'a rien à voir avec ο Μέγας Αθανάσιος…

Ouvrir dans l'éditeur
\documentclass[12pt,a4paper]{scrartcl}
\usepackage[protrusion=true]{microtype}

\usepackage{fontspec}
\usepackage{xunicode}
\usepackage{polyglossia}
\usepackage{csquotes}

\usepackage{lipsum}

\begin{filecontents}{refer.bib}
@book{athanase_vitaAntonii,
    Address = {Paris},
    Annotator = {M. G. J. M. Bartelink},
    Author = {{Athanase dAlexandrie}},
    Entrysubtype = {Book},
    Introduction = {M. G. J. M. Bartelink},
    Number = {400},
    Pagination = {Section},
    Publisher = {Éditions du Cerf},
    Series = {Sc},
    Shortseries = {Sc},
    Title = {Vie d’Antoine},
    Translator = {M. G. J. M. Bartelink},
    Year = {2004},
    Langid={french}
}

@Book{Dodgson,
  Author = {Lewis Carroll},
  Title = {The Hunting of the Snark},
  Year = {1876},
  Edition = {1},
  Publisher = {Macmillan},
}

\end{filecontents}

\usepackage[style=authortitle, backend=biber, isbn=false, citestyle=verbose-trad3, citepages=omit, bibstyle=verbose, autolang=other
]{biblatex}%
\setmainlanguage{english}
\setotherlanguages{latin, french}%,}

\usepackage[colorlinks=false]{hyperref}

\renewcommand{\newunitpunct}[0]{\addcomma\addspace}
\renewcommand{\mkbibnamelast}[1]{\textsc{#1}}
\renewcommand{\mkibid}[1]{\emph{#1}}

\addbibresource{refer.bib}

\title{Bricolage}
\author{Nemo}

\begin{document}
\frenchspacing
\maketitle

\tableofcontents

\section{Prima pars}
\lipsum[1]
cf.~\cite{athanase_vitaAntonii}
\section{Secunda pars}
\lipsum[2]
vide\autocite{athanase_vitaAntonii}
\nocite{*}
\printbibliography

\end{document}

alt text

Lien permanent

Publiée 24 Aoû '16, 23:58

Bernard's gravatar image

Bernard
3.0k15
Taux d'acceptation : 36%

Modifiée 25 Aoû '16, 12:43

@Bernard Merci beaucoup. Cette solution va me dépanner. En fait, la langue principale de mon document ne fait pas partie des celles supportées par biblatex, mais, heureusement, prise en charge par polyglossia (il s’agit du lituanien). Voilà pourquoi le latin illustre bien mon problème. Alors je suis obligé de le définir comme la langue principale. Quant a la traduction en latin des principaux termes pour un fichier latin.lbx, ce n’est pas nécessaire d’importuner le Vatican – praetor non currat de minimis, comme dit le proverbe – je pourrais le faire moi-même :)

(25 Aoû '16, 10:50) Hypnos Hypnos's gravatar image

Pourquoi ne pas créer ce fichier lithuanian.lbx? Évidemment, il y a un peu plus de 300 traductions à fournir, mais il n'y a pas de difficulté majeure – hormis le temps disponible…

(25 Aoû '16, 12:42) Bernard Bernard's gravatar image

J’ai trouvé la piste ! Par exemple, si l’on veut afficher la bibliographie en anglais (supposé que la langue principale soit l’anglais), il faut ajouter :

Ouvrir dans l'éditeur Overleaf
\DefineBibliographyStrings{english}{%
bibliography  = {Bibliography},
shorthands = {Abbreviations},
editor = {editor},
editors = {editors},
...
translatorin = {{translation and introduction}%
    {trans\adddot\ and introd\adddot}},
bytranslatorin = {{translated \lbx@lfromlang, with an introduction, by}%
    {trans\adddot\ \lbx@sfromlang, with an introd., by}},
… etc
}
Lien permanent

Publiée 24 Aoû '16, 18:08

Hypnos's gravatar image

Hypnos
314
Taux d'acceptation : 0%

Modifiée 05 Aoû '17, 22:40

Pathe's gravatar image

Pathe ♦♦
4.7k141132

2

Ce n'est pas nécessaire si vous utilisez babel ou polyglossia.Votre problème vient du fait que rien n'est prévu lorsque la langue principale est la latin.

(24 Aoû '16, 20:57) Bernard Bernard's gravatar image

@Bernard Je pense que c'est bien la réponse.

@Hypnos Personne (LaTeX y compris) ne peut supposer que l’anglais est la langue principale s'il lit dans le code \setmainlanguage{latin}. Merci de remplacer par \setmainlanguage{english}.

(24 Aoû '16, 21:51) touhami touhami's gravatar image

@Bernard Je pense que c'est bien la réponse.

@Hypnos Nul (LaTeX y compris) ne peut supposer que l’anglais est la langue principale lorsqu'il lit dans le code \setmainlanguage{latin}. Merci de remplacer par \setmainlanguage{english}.

(24 Aoû '16, 22:55) touhami touhami's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×32
×28
×15
×9
×2

Question posée : 23 Aoû '16, 21:42

Question vue : 2,464 fois

Dernière mise à jour : 25 Aoû '16, 12:43