Je compile habituellement mes fichiers avec latexmk et lualatex sans aucun soucis sur mon ordinateur habituel (Mac OS 10.12). Depuis peu, je suis également amené à travailler avec Windows 10. J'installe donc TeXLive 2018 et Perl pour que latexmk puisse fonctionner, j'importe mes fichiers habituels, mais cela ne fonctionne pas comme prévu.

Soit un fichier test.tex :

Ouvrir dans l'éditeur Overleaf
\documentclass{article}
\input{preambule.tex}
\begin{document}
\lipsum
\end{document}

Un fichier preambule.tex :

Ouvrir dans l'éditeur Overleaf
\usepackage{fontspec}
\usepackage{lipsum}

Et un fichier latexmkrc :

Ouvrir dans l'éditeur Overleaf
$lualatex='lualatex --shell-escape --synctex=1 --file-line-error %O %B';
$pdf_mode = 4;

Avec Mac OS 10.12 et MacTeX 2018 à jour, la compilation débute comme ceci et se déroule sans accroc :

Ouvrir dans l'éditeur Overleaf
Latexmk: This is Latexmk, John Collins, 17 Jan. 2018, version: 4.55.
Rule 'lualatex': Rules & subrules not known to be previously run:
   lualatex
Rule 'lualatex': The following rules & subrules became out-of-date:
      'lualatex'
------------
Run number 1 of rule 'lualatex'
------------
------------
Running 'lualatex --shell-escape --synctex=1 --file-line-error  -recorder  "test"'
------------
Latexmk: applying rule 'lualatex'...
This is LuaTeX, Version 1.07.0 (TeX Live 2018) 
 system commands enabled.
(./test.tex
...

Avec Windows 10 et TeX Live 2018 à jour également, latexmk cherche à compiler le fichier preambule.tex plutôt que le fichier maître, ce qui évidemment ne fonctionne pas :

Ouvrir dans l'éditeur Overleaf
Latexmk: This is Latexmk, John Collins, 17 Jan. 2018, version: 4.55.
Rule 'lualatex': Rules & subrules not known to be previously run:
   lualatex
Rule 'lualatex': The following rules & subrules became out-of-date:
      'lualatex'
------------
Run number 1 of rule 'lualatex'
------------
------------
Running 'lualatex --shell-escape --synctex=1 --file-line-error  -recorder  "preambule"'
------------
Latexmk: applying rule 'lualatex'...
This is LuaTeX, Version 1.07.0 (TeX Live 2018/W32TeX) 
 system commands enabled.
(./preambule.tex
...

Quelqu'un sait-il comment résoudre ce bug ?

Posée 10 Mai, 17:57

Namrod's gravatar image

Namrod
24311
Taux d'acceptation : 20%

Modifiée 01 Jul, 18:33

Pathe's gravatar image

Pathe ♦♦
4.0k130114

1

C'est fort probable à cause de l'ordre alphabétique T dans test.tex et P dans preambule.tex. Essayer avec un autre nom de fichier maître ou bien utiliser l'option @default_files = ('test.tex');.

(10 Mai, 22:42) touhami touhami's gravatar image

Le dysfonctionnement ne provenait en fait pas de Windows, mais plutôt de l'éditeur TeXworks, dans lequel il fallait passer l'option $fullname à latexmk comme indiqué ici : https://tex.stackexchange.com/questions/246566/latexmk-compiling-the-wrong-file-in-texworks.

Lien permanent

Publiée 11 Mai, 16:20

Namrod's gravatar image

Namrod
24311
Taux d'acceptation : 20%

Modifiée 11 Mai, 19:10

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×6
×3

Question posée : 10 Mai, 17:57

Question vue : 672 fois

Dernière mise à jour : 11 Mai, 19:10