J'ai du mal à utiliser le package e-french. Seul fonctionne le code suivant :

Ouvrir dans l'éditeur
\documentclass[12pt, a5paper, frenchle, landscape]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[light, largesmallcaps]{kpfonts}
\usepackage{babel}
\begin{document}
Texte.
\end{document}

Écrire dans l'en-tête efrench ou e-french à la place de frenchle donne sur ma TeXlive 2015 des erreurs de compilation :

Ouvrir dans l'éditeur
! Package babel Error: You haven't specified a language option.

Posée 01 Oct '15, 15:07

Pathe's gravatar image

Pathe ♦♦
5.5k163162
Taux d'acceptation : 59%

Modifiée 01 Oct '15, 17:51

denis's gravatar image

denis ♦♦
4.8k49


  • L'option frenchle passée à la classe de document n'est pas utilisée par la classe elle-même mais est « proposée » à chaque package chargé qui, s'il ne la connaît pas, l'ignore. En l'espèce frenchle est connue du package babel. L'option french (qui charge le module frenchb de babel) est elle aussi connue de babel, présente l'avantage de l'être également de certains packages, tel varioref, et, dans le cadre d'une utilisation avec babel, est davantage conseillée pour le français.
  • Les options efrench ou e-french ne sont connues d'aucun package et ce n'est pas cela qui va charger le package efrench.

Comme sa documentation l'indique, le package efrench est à charger au moyen de :

Ouvrir dans l'éditeur
\documentclass[12pt,a5paper,landscape]{scrartcl}
\usepackage{french}

ou :

Ouvrir dans l'éditeur
\documentclass[12pt,a5paper,landscape,french]{scrartcl}
\usepackage{mlp}

Édition (pour préciser la chose suite au commentaire). Autrement dit :

  • Si on spécifie french en option de \documentclass (\documentclass[french]{...}) et si le package babel est chargé (\usepackage{babel}), alors ce dernier est utilisé avec son module frenchb (et non french !)
  • Si on spécifie french en option de \documentclass (\documentclass[french]{...}) et si le package mlp est chargé (\usepackage{mlp}), alors le package efrench (!) est utilisé.
  • Si on veut directement utiliser le package efrench alors il faut charger le package french (\usepackage{french} !).

Il faut reconnaître qu'il y a de quoi dérouter !

Lien permanent

Publiée 01 Oct '15, 18:14

denis's gravatar image

denis ♦♦
4.8k49
Taux d'acceptation : 57%

Modifiée 01 Oct '15, 20:55

C'est subtil : selon que french est une option de babel ou une extension, ce n'est donc pas la même extension qui travaille, c'est ça ?

Il serait bon de trouver un texte à compiler permettant de juger des différences entre ces deux possibilités offertes à l'utilisateur final que sont l'option french de babel et l'extension efrench.

(01 Oct '15, 20:21) Pathe ♦♦ Pathe's gravatar image

Y a-t-il un machin, actif lors d'une compilation, qui s'appellerait french ?

Ou n'y a-t-il que deux options : frenchb et efrench ?

(01 Oct '15, 22:53) Pathe ♦♦ Pathe's gravatar image

@Pathe Je ne comprends pas la question.

(01 Oct '15, 22:57) denis ♦♦ denis's gravatar image

Ben : on parle toujours de french. Mais cela correspond-il à quelque chose ?

Puisque selon les cas cela renvoie à frenchb ou à efrench.

Mais un doute m'étreint : n'y aurait-il pas un troisième truc qui s'appellerait french, tout court ?

(02 Oct '15, 00:16) Pathe ♦♦ Pathe's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×8
×3

Question posée : 01 Oct '15, 15:07

Question vue : 4,890 fois

Dernière mise à jour : 02 Oct '15, 00:16