5
1

Je constate que la commande texdoc ouvre toujours des documents anglophones, même si les extensions sur lesquelles je m'informe sont également documentées en français. C'est par exemple le cas pour kpfonts, de Christophe Caignaert, ou pour xlop, de Jean-Côme Charpentier.

Comment faire pour que texdoc affiche ces documentations en français si elles existent ?

Posée 20 Nov '15, 11:58

Pathe's gravatar image

Pathe ♦♦
5.5k161162
Taux d'acceptation : 59%

Modifiée 14 Mai '17, 07:01

2

Si l'on connaît le nom de la version française, il faut taper texdoc <frversion>.

Sinon, taper texdoc -l <package> pour lister toutes les docs correspondant à l'extension et trouver la version française si elle existe ; puis texdoc <frversion>.

(20 Nov '15, 12:42) touhami touhami's gravatar image

Fort bien. Est-il possible d'éditer des préférences de texdoc pour que cette préférence francophone soit prise en compte automatiquement ?

(20 Nov '15, 12:48) Pathe ♦♦ Pathe's gravatar image

@Pathe Je ne crois pas que texdoc sache quelles sont les langues des documentations que renvoie texdoc -l ⟨package⟩.

(20 Nov '15, 14:22) denis ♦♦ denis's gravatar image

Ce serait utile. À qui et où puis-je suggérer cette amélioration ?

(20 Nov '15, 14:41) Pathe ♦♦ Pathe's gravatar image

@Pathe Manuel Pégourié-Gonnard, auteur de texdoc, n'en assure plus la maintenance et, malheureusement, personne ne l'a reprise (j'ai vaguement le projet de le faire, mais pas avant plusieurs mois). Ceci étant, je me demande si le jeu en vaut la chandelle : les documentations qui n'existent pas qu'en anglais sont rares et, parmi elles, celles qui ne sont pas en anglais sont assez souvent obsolètes par rapport à leur version anglaise.

(20 Nov '15, 16:27) denis ♦♦ denis's gravatar image

@denis koma-script: scrguide est la version allemande (non anglaise) et scrguien est la version anglaise!!!

(20 Nov '15, 16:58) touhami touhami's gravatar image

@touhami Je ne vois pas ce que tu veux dire par ce commentaire.

(21 Nov '15, 11:18) denis ♦♦ denis's gravatar image

@denis Il y aura toujours des surprises qui augmentent la difficulté (ici par exemple comment peut-on savoir sans ouvrir le pdf ?). Il peut arriver aussi qu'un auteur préfère monpackage.pdf pour la version française et monpackage_en.pdf pour la version en anglais.

(21 Nov '15, 11:36) touhami touhami's gravatar image

@touhami Oui, en effet. Pour cette classe, le problème est que la convention de nommage des documentations utilisée par texdoc n'est pas respectée (cf. ma réponse ci-dessous).

(21 Nov '15, 12:14) denis ♦♦ denis's gravatar image
Affichage de 5 parmi 9 Afficher 4 commentaire(s) en plus

Obtenir une document en français

Pour connaître tous les documents que texdoc identifient comme pouvant documenter un package particulier, il suffit d'utiliser l'option -l. Exemple pour xlop:

% texdoc -l xlop
 1 /usr/local/texlive/2015/texmf-dist/doc/generic/xlop/xlop-doc.pdf
   = [en] Package documentation (English)
 2 /usr/local/texlive/2015/texmf-dist/doc/generic/xlop/xlop-doc-fr.pdf
   = [fr] Package documentation (French)
 3 /usr/local/texlive/2015/texmf-dist/doc/generic/xlop/README
   = [en] Readme
 4 /usr/local/texlive/2015/texmf-dist/doc/generic/xlop/LISEZMOI
   = [fr] Readme
 Please enter the number of the file to view, anything else to skip: 

Ensuite, il suffit de choisir le numéro du document que l'on souhaite (ici 2 pour la documentation en français).

Choisir la documentation par défaut

Pour rendre ce choix permanent, vous pouvez modifier l'un des fichiers de configuration de texdoc. Pour savoir où ils sont (ou où ils peuvent être), tapez la commande suivante :

% texdoc --files 
/usr/local/texlive/2015/texmf-dist/scripts/texdoc/texdoclib.tlu 0.85
Configuration files are:
    active  /home/polo/texmf/texdoc/texdoc.cnf
    active  /usr/local/texlive/2015/texmf-dist/texdoc/texdoc.cnf
Recommended file(s) for personal settings:
    /home/polo/texmf/texdoc/texdoc.cnf

Éditez (en le créant évenuellement) le fichier recommandé et ajoutez la ligne ci-dessous:

alias xlop = xlop-doc-fr

Maintenant, la documentation par défaut de xlop fournie par texdoc sera la documentation en français. Il faut ajouter une ligne de ce type pour tous les packages proposant une documentation en français (ils ne sont pas très nombreux).

Lien permanent

Publiée 21 Nov '15, 10:48

Paul%20Gaborit's gravatar image

Paul Gaborit
58216
Taux d'acceptation : 50%

Modifiée 21 Nov '15, 12:45

Pathe's gravatar image

Pathe ♦♦
5.5k161162

En fait, la détection de la langue est déjà implémentée par texdoc. Elle s'appuie sur :

  1. la langue favorite, basée sur la « locale » utilisée (variables système telles que LANG et LC_ALL sur systèmes Unix) et sinon configurable dans le fichier de configuration texdoc.cnf au moyen de lang=⟨code⟩, où ⟨code⟩ est constituée de 2 lettres, par exemple fr ;
  2. les noms des fichiers PDF de documentation qui doivent être de la forme ⟨nom du package⟩-⟨lang⟩.pdf.

Ici, ça ne marche donc pas pour xlop et kpfonts qui n'ont pas adopté la convention du point 2 (xlop-doc au lieu de xlop et kpfonts-Doc-French au lieu de kpfonts-fr) et la solution proposée par Paul permet de s'en sortir. Mais le mieux serait de suggérer aux auteurs de ces packages de corriger cela.

En revanche, ça devrait fonctionner par exemple avec le package paresse qui adopte la convention. Chez moi :

Ouvrir dans l'éditeur
$ texdoc -l paresse
 1 /usr/local/texlive/2015/texmf-dist/doc/latex/paresse/paresse-fr.pdf
   = [fr] Package documentation (French)
 2 /usr/local/texlive/2015/texmf-dist/doc/latex/paresse/paresse.pdf
 3 /usr/local/texlive/2015/texmf-dist/doc/latex/paresse/paresse-en.pdf
   = [en] Package documentation (English)
 4 /usr/local/texlive/2015/texmf-dist/doc/latex/paresse/paresse-ex-en.pdf
   = [en] Usage examples (English)
 5 /usr/local/texlive/2015/texmf-dist/doc/latex/paresse/paresse-ex-fr.pdf
   = [fr] Usage examples (French)
Please enter the number of the file to view, anything else to skip:

paresse-fr.pdf est en tête de la liste : c'est bien la version française qui sera affichée par défaut.

Lien permanent

Publiée 21 Nov '15, 12:13

denis's gravatar image

denis ♦♦
4.8k49
Taux d'acceptation : 57%

Modifiée 04 Nov '16, 10:32

Pathe's gravatar image

Pathe ♦♦
5.5k161162

Euh… question de newb' : où saisit-on `$ texdoc -l paresse ? Dans la barre de la console, cela ne donne pas grand chose…

(23 Mai '16, 16:49) fred02840 fred02840's gravatar image

@fred02840 Sous Linux et Mac OS, dans n'importe quel émulateur de terminal. Sous Windows, dans l'Invite de commande MS-DOS (à moins qu'un meilleur émulateur de terminal ait été installé).

(23 Mai '16, 17:24) denis ♦♦ denis's gravatar image

@fred02840 Le caractère $ (ou, dans ma réponse, le caractère %) ne doit pas être saisi. C'est juste pour montrer l'invite (ou le "prompt") de l'interpréteur de commandes.

(27 Mai '16, 18:57) Paul Gaborit Paul%20Gaborit's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×8
×8
×7

Question posée : 20 Nov '15, 11:58

Question vue : 3,036 fois

Dernière mise à jour : 27 Mai '16, 18:57