J'utilise actuellement le paquet yathesis pour écrire (merci encore pour cet outil formidable 🥇 ) mais là, j'obtiens toujours le message d'erreur suivant :

Fichier : yathesis.cls Type : avertissement Message :Generic hook 'package/after/glossaries' is deprecated.

Je ne pense pas que ce message soit "fatal" mais j'aimerais comprendre... J'utilise MacOS Ventura 13.1 et Texstudio 4.4.1.

J'ai trouvé dans le paquetage de la classe cette partie de code :

  \AddToHook{begindocument/before}{%
      \@ifpackageloaded{glossaries}{%
        \RequirePackage{glossaries-babel}%
      }{%
      }%
    }%
    }%
    \AddToHook{begindocument/before}{%
      \@ifpackageloaded{glossaries}{%
        \IfLanguageName{english}{%
          \makeatletter
          \let\glossariescaptionsenglish\undefined
          \input{glossaries-english.ldf}
          \makeatother
        }{%
        }%
      }{%
      }%
    }%

Sur un autre forum, on m'a répondu :

hm, in part it is my fault. The hopatch package uses the old patch name. I will handle that, but probably yathesis should stop to use hopatch, so notify the author.

Je suis Ă  votre disposition pour de plus amples informations,

Posée 07 Jan, 19:49

gimshps's gravatar image

gimshps
1956
Taux d'acceptation : 100%

Modifiée 07 Jan, 19:50

1

Il s'agit d'une erreur dans le package hopatch signalée par Ulrike Fischer : merci à elle. Je vais suivre son conseil et ne plus faire charger par yathesis ce package (ni filehook désormais inutile).

(07 Jan, 21:07) denis ♦♦ denis's gravatar image

Merci pour le témoignage !

(07 Jan, 21:17) denis ♦♦ denis's gravatar image

merci Ă  vous!

(08 Jan, 10:58) gimshps gimshps's gravatar image

Merci pour le remerciement :) mais les formules de politesse et les signatures sont Ă  Ă©viter.

(08 Jan, 16:05) denis ♦♦ denis's gravatar image

Savez-vous quand aura lieu la mise Ă  jour du paquet pour utiliser les glossaires ?

(18 Jan, 13:39) gimshps gimshps's gravatar image

La mise à jour du package hopatch a eu lieu le 7 janvier. Ne règle-t-elle pas le problème rencontré (qui, d'ailleurs, semble n'être qu'un warning et n'est donc pas gênant outre mesure) ?

(19 Jan, 09:44) denis ♦♦ denis's gravatar image

effectivement elle le règle ! (en réalité, je ne savais pas que sur TeXstudio il fallait compiler à part le glossaire) merci!

(22 Jan, 11:54) gimshps gimshps's gravatar image

Ce n'est pas propre à (l'éditeur) TeXstudio. Pour un glossaire à jour, la compilation usuelle (pdf|xe|lua)latex doit être suivie de : (1) 1 compilation makeglossaries, (2) 1 compilation (pdf|xe|lua)latex et ce, dans le cas (et — essentiellement — seulement dans le cas) où 1 terme ou acronyme (au moins) : soit est nouvellement employé, soit (déjà employé) est modifié ou n’est plus employé ou voit une de ses occurrences changer de page.

(22 Jan, 14:48) denis ♦♦ denis's gravatar image
Affichage de 5 parmi 8 Afficher 3 commentaire(s) en plus

Au vue des commentaires précédents, la question est résolue.

Lien permanent

Publiée 10 Avr, 16:06

gimshps's gravatar image

gimshps
1956
Taux d'acceptation : 100%

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

RĂ©ponses

RĂ©ponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numĂ©rotĂ©e : 1. Foo 2. Bar
  • Pour ajouter un passage Ă  la ligne, ajoutez deux espaces Ă  l'endroit oĂą vous souhaitez que la ligne commence.
  • Les balises HTML de base sont Ă©galement prises en charge.