Je viens pour la première fois de faire un copié-collé d'un court texte en vietnamien dans LyX.

Lorsque je demande l'exportation du texte en pdf, je n'obtiens que le message d'erreur :

Ouvrir dans l'éditeur Overleaf
Commande LaTeX pour le caractère "ô avec un accent aigu supplémentaire" introuvable (point 0x1ed1 du code)".

J'ai pourtant installé texlive-babel-vietnamese. Que dois-je faire pour compléter mon LyX ?

Je ne peux utiliser directement LaTeX : cela fait une vingtaine d'années que j'écris avec LyX (je suis professeur, actuellement retraité et reconverti au bénévolat).

Posée 08 Déc '20, 11:05

Atome%20Kid's gravatar image

Atome Kid
112
Taux d'acceptation : 0%

Modifiée 08 Déc '20, 11:21

Pathe's gravatar image

Pathe ♦♦
6.4k5123200

@Atome Kid : bienvenue sur TeXnique !

N'en prenez pas ombrage : pour aller à l'essentiel, j'ai édité votre message.

(08 Déc '20, 11:23) Pathe ♦♦ Pathe's gravatar image

Je reconnais avoir fait une erreur : mes documents étaient déclarés en français par défaut. J'ai donc redéclaré ce document en vietnamien. Or à la demande d'exporter en pdf, j'obtiens le message d'erreur : "Package inputenc Error: Invalid UTF-8 byte "C1. Package inputenc Error: Invalid UTF-8 byte "9B. Package inputenc Error: Invalid UTF-8 byte 91" Package inputenc Error: Invalid UTF-8 byte "C1. Package inputenc Error: Invalid UTF-8 byte "9B. LaTeX Error: Command DH unavailable in encoding T5. LaTeX Error: Command DH unavailable in encoding T5. LaTeX Error: Command DH unavailable in encoding T5. LaTeX Error: Command DH unavailable in encoding T5. LaTeX Error: Command DH unavailable in encoding T5.

Description : maketitle

The document does not appear to be in UTF-8 encoding. Try adding UseRawInputEncoding as the first line of the file or specify an encoding such as usepackage [latin1]{inputenc} in the document preamble. Alternatively, save the file in UTF-8 using your editor or another tool"

Merci ! Atome Kid

(08 Déc '20, 11:41) Atome Kid Atome%20Kid's gravatar image

Ajouter dans le préambule du document : usepackage[latin1]{inputenc} ne change rien au résultat. Merci ! Atome Kid.

(08 Déc '20, 11:44) Atome Kid Atome%20Kid's gravatar image

\usepackage[utf8x]{inputenc}, peut-être ?

(08 Déc '20, 11:59) Pathe ♦♦ Pathe's gravatar image

Hélas non, j'ai ajouté dans le préambule : usepackage[utf8x]{inputenc} et j'obtiens : " usepackage [utf8x]{inputenc} The package inputenc has already been loaded with options: [utf8] There has now been an attempt to load it with options [latin1] Adding the global options: utf8,latin1 to your documentclass declaration may fix this. Try typing to proceed." Sans plus : pas d'exportation pdf ! Merci ! Atome Kid.

(08 Déc '20, 13:26) Atome Kid Atome%20Kid's gravatar image

Ce document, trouvé sur le CTAN, pourrait vous aider.

(08 Déc '20, 13:53) Pathe ♦♦ Pathe's gravatar image
1

Puis-je me permettre de renvoyer à la question que j'avais posée, il y a un an environ ? [https://texnique.fr/osqa/questions/8027/latex-et-vietnamien]

(08 Déc '20, 14:29) fred02840 fred02840's gravatar image
Affichage de 5 parmi 7 Afficher 2 commentaire(s) en plus

Il y a un an, je me posais la même question, et j'avais trouvé la solution suivante qui m'avait parfaitement convenue (j'ai installé une TeXlive complète, ce qui aide). Mais vos besoins sont peut-être différents.

Ouvrir dans l'éditeur Overleaf
\documentclass{scrreprt} % Ou n'importe quel type de document
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[vietnamese,french]{babel}
\usepackage{mwe}

\begin{document} 
    \foreignlanguage{vietnamese}{Nguyễn Phúc Vĩnh Thụy}
\end{document}

Ce qui donne :

alt text

Lien permanent

Publiée 08 Déc '20, 14:33

fred02840's gravatar image

fred02840
3.5k263141
Taux d'acceptation : 16%

Modifiée 08 Déc '20, 14:37

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×18
×4
×2

Question posée : 08 Déc '20, 11:05

Question vue : 175 fois

Dernière mise à jour : 08 Déc '20, 14:37