Comment faire pour avoir des espaces semblables entre les éléments d'une table des matières ? Ici, les nombres elzéviriens se chevauchent, ce qui n'est pas du meilleur goût :

Ouvrir dans l'éditeur Overleaf
\documentclass[toc=sectionentrydotfill]{scrreprt}
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    \usepackage[oldstylenums]{kpfonts}
    \usepackage{setspace} % gestion des interlignes, id pour les notes
    \usepackage{mwe}
    \begin{document}
    \tableofcontents
    \newpage
    \section*{Titre 1}
    \addcontentsline{toc}{section}{Titre 1}
    \lipsum[1-50]
    \section*{Titre 2}
    \addcontentsline{toc}{section}{Titre 2}
    \lipsum[50-100]
    \section*{Titre 3}
    \addcontentsline{toc}{section}{Titre 3}
    \lipsum[100-150]
    \section*{Titre 4}
    \addcontentsline{toc}{section}{Titre 4}
    \lipsum[1-39]
    \end{document}

Modification : bon, évidemment, Overleaf donne un résultat satisfaisant… Voici une idée de ce que cela donne :

Nouvel ECM (à la demande de @touhami, ci-dessous) :

Ouvrir dans l'éditeur Overleaf
\documentclass[french,a5paper,toc=sectionentrydotfill,DIV=12,twoside]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[oldstylenums]{kpfonts}
\usepackage{babel}
\usepackage{multicol}
\usepackage{mwe}
\usepackage{lipsum}
\frenchbsetup{StandardLists=false,og = «, fg = »}
\usepackage{setspace}
\setlength{\parskip}{0.2cm}
\usepackage[hyphenation,parindent,lastparline]{impnattypo} 
\usepackage[all]{nowidow}
\selectlanguage{french}
\exhyphenpenalty=10000 
\usepackage[babel=true]{csquotes}
\usepackage{caption}
\usepackage{graphicx, threeparttable}
\DeclareCaptionFormat{sanslabel}{#3}
\usepackage[normalem]{ulem}
\usepackage{capt-of}
\usepackage{xspace} 
\usepackage{textcomp}
\usepackage{reledmac}
\usepackage{fancybox}
\usepackage{multirow}
\usepackage{enumerate}
\usepackage{enumitem}
\usepackage{tikz}
\usepackage{pgfplots}
\usepackage{eurosym}
\usepackage[load-configurations = abbreviations]{siunitx}
\sisetup{locale = FR, detect-all, group-minimum-digits=4}
\usepackage{booktabs}
\usepackage{dcolumn}
\usepackage{tabularx}
\usepackage{array, makecell, boldline}
\usepackage[hidelinks]{hyperref}
\hypersetup{
    colorlinks=true,
    urlcolor=blue,
    linkcolor=black,
    breaklinks=true
}
\def\frenchcontentsname{}
 \setuptoc{toc}{leveldown}

\begin{document}

{\small
\tableofcontents
}

\newpage

\section*{Titre 1}
\addcontentsline{toc}{section}{Titre 1}

\subsection*{S/titre 1.1}
\addcontentsline{toc}{subsection}{S/titre 1.1}

\subsection*{S/titre 1.2}
\addcontentsline{toc}{subsection}{S/titre 1.2}

\newpage

\section*{Titre 2}
\addcontentsline{toc}{section}{section 2.1}

\subsection*{S/titre 2.1}
\addcontentsline{toc}{subsection}{S/titre 2.1}

\subsection*{S/titre 2.2}
\addcontentsline{toc}{subsection}{S/titre 2.2}

\newpage

\section*{Titre 3}
\addcontentsline{toc}{section}{section 3.1}

\subsection*{S/titre 3.1}
\addcontentsline{toc}{subsection}{S/titre 3.1}

\subsection*{S/titre 3.2}
\addcontentsline{toc}{subsection}{S/titre 3.2}

\end{document}

Posée 26 Déc '19, 18:47

fred02840's gravatar image

fred02840
2.8k3582
Taux d'acceptation : 9%

Modifiée 02 Jan, 02:33

1

Comment cela, ils se chevauchent? Ils chevauchent le cadre, mais c'est avant tout un problème avec hyperref. Pourquoi ne pas le supprimer ? Il n'est pas non plus d'un goût exquis…

(26 Déc '19, 19:14) Bernard Bernard's gravatar image

@bernard. C'était bien cela : les espacements sont maintenant corrects. Cependant, je perds les indications d'hyperliens… Mais je vais poser une question à ce sujet.

(26 Déc '19, 19:44) fred02840 fred02840's gravatar image

Il suffit de demander à colorier Titre1, &c. (sil m'en souvient bien, c'est l'option colorlinks).

(26 Déc '19, 20:07) Bernard Bernard's gravatar image
1

Réglages d'hyperref (en options de package ou via la commande \hypersetup):

frenchlinks=false, si j'ai bien lu, les cadres hideux (par défaut) sont frenchlinks=true

colorlinks= pour choisir la couleur du texte lié.

(j'utilise principalement hidelinks, le lien n'apparaît qu'au passage du curseur, c'est plus confortable à lire, et dans une toc le lien est sur le titre ou (et) le numéro de page, des choix évidents.)

(26 Déc '19, 21:36) joseph-tux joseph-tux's gravatar image
1

Pourriez vous poster un vrai ECM ? un exemple qui reproduit le problème ?

Certes mon installation n'est pas à jour, je n'est pas ce problème chez moi.

(27 Déc '19, 10:43) touhami touhami's gravatar image

@touhami. Je peux mettre l'intégralité de mon fichier, pour qu'on ait l'ensemble des paquets utilisés, ce qui risque d'être un tantinet lourdingue. Je peux le faire, mais la solution de @joseph-tux s'est révélée concluante : le paramétrage d'hyperref était bien en cause…

(27 Déc '19, 12:00) fred02840 fred02840's gravatar image

Je ne peut pas reproduire le problem avec texlive2019

(27 Déc '19, 19:13) samcarter samcarter's gravatar image
1

@fred02840 : si la solution de @joseph-tux vous convient, pourriez-vous rédiger un ECM la mettant en valeur, et expliquer ce en quoi elle résout votre problème ? Cela serait utile à d'autres.

(30 Déc '19, 21:00) Pathe ♦♦ Pathe's gravatar image
1

@Pathe Comparer la taille de police entre les deux cotés (gauche-droite) de la table des matières.

(31 Déc '19, 12:34) touhami touhami's gravatar image

Effectivement : il y a une différence… de taille. comment la résoudre ?

(01 Jan, 18:42) fred02840 fred02840's gravatar image
3

On aura besoin d'un ECM. Vous pouvez commencer, par exemple, par garder le préambule et le titres des sections. Ensuite, essayer de réduire le préambule en enlevant les définitions des commandes et les packages.

Attention: n'oubliez pas de compiler au moins deux fois après chaque modifications pour voir si le problème persiste.

(01 Jan, 23:32) touhami touhami's gravatar image

@touhami. Je la place en-dessous de la première, ci-dessus

(02 Jan, 02:25) fred02840 fred02840's gravatar image
Affichage de 5 parmi 12 Afficher 7 commentaire(s) en plus

Le problème vient de {\small \tableofcontents }. En effet il me semble comme un bug de koma-sript.

Voici un ECM :

Ouvrir dans l'éditeur Overleaf
\documentclass[french]{scrreprt}
\usepackage{lmodern}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\begin{document}

{\tiny
\tableofcontents 
}

\section{Titre 1}
\subsection{S/titre 1.1}

\end{document}

Pour résoudre ce problème il faut redéfinir la commande responsable de la mise en page des entrées.

Ouvrir dans l'éditeur Overleaf
\documentclass[french]{scrreprt}
\usepackage{lmodern}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\usepackage{etoolbox}
\makeatletter 
\patchcmd{\scr@dte@tocline}{\normalfont\normalsize}{}{}{} 
\makeatother

\begin{document}

{\small
\tableofcontents 
}

\section{Titre 1}
\subsection{S/titre 1.1}

\end{document}
Lien permanent

Publiée 02 Jan, 10:50

touhami's gravatar image

touhami
7.3k27
Taux d'acceptation : 57%

Modifiée 02 Jan, 14:16

Pathe's gravatar image

Pathe ♦♦
5.7k175167

1

Pourquoi continuez-vous à utiliser \section*{titre} \addcontentsline{toc}{subsection}{titre} ?

(02 Jan, 10:53) touhami touhami's gravatar image

Options d'hyperref : frenchlinks=false,colorlinks=true,linkcolor=blue

Ouvrir dans l'éditeur Overleaf
\documentclass[toc=sectionentrydotfill]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}
\usepackage[oldstylenums]{kpfonts}
\usepackage{setspace}
\usepackage{mwe}
\hypersetup{frenchlinks=false,colorlinks=true,linkcolor=blue}
\begin{document}
\tableofcontents
\newpage
\section*{Titre 1}
\addcontentsline{toc}{section}{Titre
1}
\lipsum[1-50]
\section*{Titre 2}
\addcontentsline{toc}{section}{Titre
2}
\lipsum[50-100]
\section*{Titre 3}
\addcontentsline{toc}{section}{Titre
3}
\lipsum[100-150]
\section*{Titre
4}
\addcontentsline{toc}{section}{Titre
4}
\lipsum[1-39]
\end{document}
Lien permanent

Publiée 31 Déc '19, 15:10

joseph-tux's gravatar image

joseph-tux
620312
Taux d'acceptation : 6%

Modifiée 02 Jan, 14:15

Pathe's gravatar image

Pathe ♦♦
5.7k175167

On peut utiliser \RedeclareSectionCommands pour modifier la table des matières :

Ouvrir dans l'éditeur Overleaf
\documentclass[french]{scrreprt}
\usepackage{lmodern}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\newcommand*\tocentryformat[1]{{\tiny#1}}
\RedeclareSectionCommands
  [
    tocentryformat=\tocentryformat,
    tocpagenumberformat=\tocentryformat
  ]
  {section,subsection,subsubsection,paragraph,subparagraph}

\begin{document}

\tableofcontents

\section{Titre 1}
\subsection{S/titre 1.1}

text

\end{document}
Lien permanent

Publiée 02 Jan, 11:24

samcarter's gravatar image

samcarter
3.2k212
Taux d'acceptation : 50%

Modifiée 02 Jan, 14:14

Pathe's gravatar image

Pathe ♦♦
5.7k175167

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×16
×16
×13
×11

Question posée : 26 Déc '19, 18:47

Question vue : 231 fois

Dernière mise à jour : 02 Jan, 11:25