Dans un précédent message, je relevais l'incompatibilité d'humeur entre \pause et allowframebreak. Le problème se repose sans \pause, mais, ce qui revient au même résultat, avec \beamerdefaultoverlayspecification{<+->} placé dans le préambule.

J'obtiens bien deux frames, mais seul le premier item de la frame 1 apparaît en clair.

Ouvrir dans l'éditeur Overleaf
\documentclass[14pt,c]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\beamerdefaultoverlayspecification{<+->}

\begin{document}
\begin{frame}[allowframebreaks=0.75]
    \frametitle{Titre de frame}
    \begin{itemize}
        \item blabla 1; 
        \item  blabla 2 ;
        \item blabla 3;
        \item blabla 1; 
        \item  blabla 2 ;
        \item blabla 3;
        \item blabla 1; 
        \item  blabla 2 ;
        \item blabla 3;
        \item blabla 1; 
        \item  blabla 2 ;
        \item blabla 3;
    \end{itemize}
\end{frame}
\end{document}

Posée 28 Aoû, 22:30

fred02840's gravatar image

fred02840
2.5k3177
Taux d'acceptation : 10%

Modifiée 28 Aoû, 22:40


allowframebreaks n'est pas compatible avec \pause. La documentation de beamer dit :

"The use of this option is evil" - L'utilisation de cette option est diabolique

et

"You can use the option allowframebreaks [...], though you cannot use overlays then" - Vous pouvez utiliser l'option allowframebreaks [...], mais vous ne pouvez pas utiliser overlays en même temps

Pour éviter cet problème on pourrait faire quelque chose comme ça :

Ouvrir dans l'éditeur Overleaf
\documentclass[14pt,c]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[french]{babel}
\beamerdefaultoverlayspecification{<+->}

\begin{document}
\begin{frame}
    \frametitle{Titre de frame}

    \begin{onlyenv}<-6>
        \begin{itemize}
            \item blabla 1; 
            \item  blabla 2 ;
            \item blabla 3;
            \item blabla 4; 
            \item  blabla 5 ;
            \item blabla 6;
         \end{itemize}
     \end{onlyenv}

     \begin{onlyenv}<.(1)->
         \begin{itemize}
            \item blabla 7; 
            \item  blabla 8 ;
            \item blabla 9;
            \item blabla 10; 
            \item  blabla 11 ;
            \item blabla 12;
        \end{itemize}
    \end{onlyenv}

\end{frame}
\end{document}

alt text

Lien permanent

Publiée 28 Aoû, 22:59

samcarter's gravatar image

samcarter
2.8k211
Taux d'acceptation : 48%

Modifiée 29 Aoû, 00:24

Pathe's gravatar image

Pathe ♦♦
5.6k166162

@samcarter. Toujours la bonne solution à tout : bravo, ça marche. J'ai tenté en vain d'appliquer ce qui est dit là : https://tex.stackexchange.com/questions/57212/pause-and-framebreak-in-the-same-frame

(28 Aoû, 23:17) fred02840 fred02840's gravatar image

@fred02840 C'était mon plaisir ! J'aime les question avec beamer :)

(28 Aoû, 23:23) samcarter samcarter's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×46
×1

Question posée : 28 Aoû, 22:30

Question vue : 236 fois

Dernière mise à jour : 28 Aoû, 23:33