Je travaille sous Windows 10 avec la distribution TeX Live et l'éditeur TeXstudio.

Grâce à TeX Live Manager, j'ai pu télécharger de nouveaux packages mais, une fois dans TeXstudio, il m'indique « package introuvable » et, pour les commandes, « commande inconnue ».

Pour autant, lorsque je compile, le symbole voulu (en l’occurrence le double crochet pour les intervalles d'entiers) apparaît.

Deux suppositions (peut-être très fausses toutes les deux) :

  • un problème de paramétrage de TeXstudio ; mais alors comment le paramétrer correctement ?
  • j'avais installé Miktex il y a plusieurs années, pour pouvoir utiliser des petits logiciels type pdfadd ; n'y aurait-il pas un conflit entre TeX Live et MikTeX ?

Posée 24 Jui, 18:34

Leisio's gravatar image

Leisio
211
Taux d'acceptation : 0%

Modifiée 24 Jui, 18:58

Pathe's gravatar image

Pathe ♦♦
4.4k135123

@Leisio Les formules de politesse et les signatures sont à éviter : celle(s) de votre contribution a (ont) été supprimée(s).

Par ailleurs, à quel moment est-ce que TeXstudio indique « package introuvable » et « commande inconnue » ?

(24 Jui, 19:03) Pathe ♦♦ Pathe's gravatar image

Je vous propose de commencer par compiler le fichier

\documentclass{article} \begin{document} foo \end{document}

en utilisant TeXstudio et une deuxième fois en utilisant la ligne de commande.

(24 Jui, 23:22) touhami touhami's gravatar image

Ne faudrait-il pas rafraichir la base de donnée (équivalent de texhash sous Windows) ?

Utiliser \listfiles (en tout début de fichier) pour connaître la version du paquetage afin de savoir si c'est celle de MikTeX ancien ou de TeXLive récent qui est utilisée.

(25 Jui, 12:31) DRI DRI's gravatar image

@DRI : j'ai utilisé la commande listfiles mais je ne sais pas comment analyser (lire) le résultat. Cela m'indique "stmaryrd.sty 1994/03/03 St Mary's Road symbol package" ou encore "fourier.sty 2005/01/01 1.4 fourier-GUTenberg package" alors que ces deux package sont toujours estampillés "introuvables"

(03 Jul, 13:39) Leisio Leisio's gravatar image

@touhami : j'ai compilé avec TexStudio et il n'y a aucun problème ; en revanche, je ne sais pas faire cela avec la "ligne de commande" (je sais y accéder mais pas ce que je dois y saisir).

(03 Jul, 13:45) Leisio Leisio's gravatar image

À partir de votre fichier créer un fichier ECM (par exemple fichiereECM.tex) de la forme suivante

\documentclass{article} \usepackage{package1} \usepackage{package2} ... \usepackage{packageN} \begin{document} foo \end{document}

Après la compilation, cliquer sur le bouton problèmes vous devez voir un message ! LaTeX Error: File packageX.sty not found.. Commenter la ligne \usepackage{packageX} et recommence. Cela vous donne la liste des packages manquants.

(03 Jul, 17:42) touhami touhami's gravatar image
Affichage de 5 parmi 6 Afficher 1 commentaire(s) en plus
Soyez le premier à répondre à cette question !
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×16
×6
×2

Question posée : 24 Jui, 18:34

Question vue : 288 fois

Dernière mise à jour : 03 Jul, 17:45