Comme vous le savez probablement, il est possible, sous TeXmaker, de personnaliser nos commandes pour que l'auto-complétion les détectent. Pour cela, il suffit d'aller sous texmaker dans le menu « utilisateur » et « personnaliser complétion ».

Cependant, même après avoir sauvegardé le fichier de configuration ini, mes commandes personnalisées ne se retrouvent pas enregistrées dans ce fichier de configuration. En effet, la configuration du choix du moteur de compilateur est enregistré, mais pas les commandes qui ont été rajoutées. C'est-à-dire que si je souhaite travailler sur un autre PC en exportant ce fichier de configuration, je suis obligé de me retaper toutes mes commandes personnalisées pour que l'auto-complétion de ces commandes soit opérationnelle.

Savez-vous s'il y a une autre méthode ou bien est-ce un oubli des développeurs ?

Par contre, les balises de raccourci créés dans le menu « utilisateur » sont bien sauvegardées dans le fichier de configuration :

alt text

Posée 13 Fév, 02:27

floyd973's gravatar image

floyd973
15139
Taux d'acceptation : 0%

Modifiée 13 Fév, 12:37

Pathe's gravatar image

Pathe ♦♦
5.7k178169

1

Pour moi, ces commandes sont bien dans le fichier texmaker.ini.

(13 Fév, 09:25) touhami touhami's gravatar image

Les balises créées dans l'autre menu "utilisateur" (voir image), elles, sont bien enregistrées dans le fichier texmaker ini.

Par contre, et c'est ce dont je parle, les commandes éditées dans le menu "utilisateur" --> "personnaliser complétion". Chez moi elles ne se retrouvent pas le fichier texmaker ini. C'est bien de cela dont vous parlez ?

(13 Fév, 11:47) floyd973 floyd973's gravatar image
1

Pour moi (sous TeXmaker 4.5) les deux types des commandes sont là. Les commandes ajoutées par le panneau "Utilisateur" (situé à gauche) sont inscrites sous l'entrée : User\TagList=, alors que celles ajoutées par le menu Utilisateur -> Personnaliser Completion sont sous l'entrée : Editor\UserCompletion=.

(13 Fév, 15:21) touhami touhami's gravatar image

Ben chez moi cela ne fonctionne pas. D'ailleurs en ouvrant le fichier texmaker ini , j'ai cela : "EditorUserCompletion=@Invalid()"

(13 Fév, 18:09) floyd973 floyd973's gravatar image

alt text

Je vais essayer avec une ancienne version de texmaker pour voir !

Lien permanent

Publiée 13 Fév, 18:10

floyd973's gravatar image

floyd973
15139
Taux d'acceptation : 0%

J'ai restauré la configuration par défaut, j'ai de nouveau essayé et cela fonctionne.

En fait, dès que l'on ferme texmaker les personnalisations sont enregistrées automatiquement dans ....AppDataRoamingx1mtexmaker.ini. Attention : c'est un dossier caché. Il faut penser à activer l'affichage des dossiers cachés

Quand je chargeais mon fichier "texmaker.ini" que j'avais au préalable sauvegardé dans un autre dossier de mon disque dur, texmaker ne le trouvait pas. Il faut juste s'assurer que le fichier de configuration soit modifié ou enregistré dans le dossier spécifié dans le second paragraphe.

Enfin je recommencerai à gagner du temps.

Merci à vous

Lien permanent

Publiée 13 Fév, 23:54

floyd973's gravatar image

floyd973
15139
Taux d'acceptation : 0%

Modifiée 13 Fév, 23:55

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×8
×3
×2
×1
×1

Question posée : 13 Fév, 02:27

Question vue : 108 fois

Dernière mise à jour : 13 Fév, 23:55