Ce blocage à la compilation est récurrent, et l'origine de ce caractère invalide est toujours très long à identifier, malgré l'information sur la ligne concernée.

N'y aurait-il pas un moyen de forcer la compilation à se poursuivre, afin que ce caractère invalide apparaisse clairement ? Ou un moyen de demander à inputenc d'être plus explicite ?

Posée 05 Oct, 16:57

joseph-tux's gravatar image

joseph-tux
578312
Taux d'acceptation : 6%

Modifiée 16 Oct, 10:45

Pathe's gravatar image

Pathe ♦♦
5.7k169164


Lors du blocage de la compilation par pdflatex, au lieu de sortir par «X», on peut poursuivre avec «R».

Lien permanent

Publiée 05 Oct, 16:59

joseph-tux's gravatar image

joseph-tux
578312
Taux d'acceptation : 6%

Modifiée 05 Oct, 17:00

J'ai trouvé cette réponse avant d'adresser la question, mais tout compte fait, ça pourra peut-être servir à d'autres. Sinon, les modérateurs peuvent supprimer cette question sans que je m'en offusque;)

(05 Oct, 17:02) joseph-tux joseph-tux's gravatar image
2

Deux remarques :

– il me semblait que le fichier .log contenait le caractère fautif ; je crois me souvenir de l'avoir copié, puis cherché sur internet, ce qui s'était révélé pratique ;

– choisir utf8x en lieu et place de utf8 diminue le risque d'erreur en augmentant le nombre de caractères compilables.

(05 Oct, 18:01) Pathe ♦♦ Pathe's gravatar image
1

@Pathe Il y a des problèmes avec utf8x (https://tex.stackexchange.com/a/13070/36296)

(05 Oct, 18:19) samcarter samcarter's gravatar image
2

D'après ltxnews30, la gestion de l'utf8 devrait être nettement améliorée avec la fournée qui doit sortir dans les prochains jours.

(05 Oct, 20:35) Bernard Bernard's gravatar image

@Bernard,

C'est une bonne nouvelle. Néanmoins la question subsiste lorsque le problème n'est pas l'UTF8, c'est à dire lorsqu'il y a réellement un caractère invalide, non utf8.

Cependant, j'ai bien rencontré ce problème de l'utf8 valide avec le fichier de configuration de la classe lettre, réglé en notant «\'{e}» au lieu de «é» etc.

Aux autres,

merci aussi pour votre contribution; il me semble avoir parfois réglé le problème avec utf8x, et rencontré d'autres problèmes avec ce même utf8x, mais c'est loin dans ma mémoire de vieux poisson rouge.

(06 Oct, 15:16) joseph-tux joseph-tux's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×5
×1

Question posée : 05 Oct, 16:57

Question vue : 481 fois

Dernière mise à jour : 06 Oct, 15:17