J'ai beaucoup de mal à faire des guillemets, j'ai utilisé les macros

  • \og et \fg
  • \guillemotleft et \guillemotright
  • \frquotes

En fait, les guillemets apparaissent bien dans on fichier .DVI, mais le compilateur me signale des erreurs et il semblerait que l'option latin1 du package babel n'est pas compatible avec toutes ces macros.

J'utilise MiKTeX et TeXnicCenter sous Win10 pro. Vous trouverez ci-joint un bout de mon préambule.

Ouvrir dans l'éditeur Overleaf
\documentclass[french]{amsbook}%
%
%----------------------------------------------------------
%%%% début encodage et gestion du français %%%%%%%%%%%%%%%%%%%
\usepackage[T1]{fontenc}
\usepackage[latin1]{inputenc}
\usepackage{lmodern} % fortement conseillé pour les pdf. On peut mettre autre chose : kpfonts, fourier,...
\usepackage{babel}
%%%% fin encodage des caractères fraçais %%%%%%%%%%%%%%%
\usepackage{graphicx}%
%%------------------------------------------------------------
%%%% Dimensionnement de la page et marques de découpe
\usepackage[paperwidth=17truecm, paperheight=24truecm, bottom=2truecm, right=2truecm, height=21truecm]{geometry}

Posée 24 Déc '18, 23:14

Loukami's gravatar image

Loukami
212
Taux d'acceptation : 100%

Modifiée 25 Déc '18, 14:12

denis's gravatar image

denis ♦♦
4.3k39

@Loukami Les formules de politesse et les signatures sont à éviter : celle(s) de votre contribution a (ont) été supprimée(s).

(25 Déc '18, 14:11) denis ♦♦ denis's gravatar image

@Loukami Attention ! Les contre-obliques (\) saisies telles quelles dans les contributions ne sont visibles que si elles sont insérées en tant que ⟨code⟩. Pour insérer du ⟨code⟩, notamment des commandes LaTeX, cf. la FAQ Comment mettre en forme ma contribution ?. Merci de corriger votre contribution si cela n'a pas déjà été fait.

(25 Déc '18, 14:12) denis ♦♦ denis's gravatar image

@Loukami Merci d'essayer de fournir un ECM.

(25 Déc '18, 14:14) denis ♦♦ denis's gravatar image

Avec une distribution TeX Live 2018 à jour, je ne constate aucune erreur de compilation avec ce préambule (babel est à mettre en dernier) et les commandes \og, \fg, \frquote (et non \frquotes). Merci de fournir un ECM et le message d'erreur.

(25 Déc '18, 14:19) denis ♦♦ denis's gravatar image

J'utilise plutôt \frquote{blabla} mais en prenant soin de placer \usepackage{csquotes} dans le préambule : le système des guillemets à la française est ainsi pleinement respecté (surtout en cas de paragraphes multiples).

(26 Déc '18, 19:26) fred02840 fred02840's gravatar image

@fred02840 \frquote, fourni par le module babel-french (donc par le package babel et, préférablement au niveau de \documentclass, l'option french) ne nécessite pas le package csquotes, ce dernier fournissant la commande \enquote qui, effectivement, respecte le système des guillemets à la française mais est moins puissante (cf. la documentation de babel-french).

(26 Déc '18, 20:06) denis ♦♦ denis's gravatar image
Affichage de 5 parmi 6 Afficher 1 commentaire(s) en plus

alt text

Lien permanent

Publiée 31 Déc '18, 14:28

Loukami's gravatar image

Loukami
212
Taux d'acceptation : 100%

@Loukami Votre réponse n'en est pas une : pourriez-vous poster la solution que vous avez trouvée ? Cela serait utile à la communauté.

(31 Déc '18, 16:39) Pathe ♦♦ Pathe's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×3

Question posée : 24 Déc '18, 23:14

Question vue : 292 fois

Dernière mise à jour : 31 Déc '18, 16:39