je rédige ma thèse avec yathesis et depuis peu j'ai un problème avec ma bibliographie.

À chaque fois que je rajoute \printbibliography automatiquement la commande qui la suit directement devient « undefined control sequence » et rien ne se modifie alors que si j'enlève \printbibliography la compilation se fait normalement... D'où peut provenir le problème? Directement dans le fichier bib ?

ECM à compiler avec pdflatex + biber. (par touhami).

Ouvrir dans l'éditeur Overleaf
\documentclass{article}

\begin{filecontents}{\jobname.bib}
   @article{foo,
    title = {Titre d’article},
    journaltitle = {Annales},
    author = {Auteur},
    year = {2007}
}
\end{filecontents}

\usepackage[utf8]{inputenc}
\usepackage[backend=biber,safeinputenc]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}
\cite{foo}.

\printbibliography
\end{document}

Posée 06 Jul, 17:00

Aur%C3%A9lienCocq's gravatar image

AurélienCocq
4419
Taux d'acceptation : 0%

Modifiée 08 Jul, 01:17

touhami's gravatar image

touhami
2.5k26

Il nous faudrait un ECM ;)

(06 Jul, 17:05) denis ♦♦ denis's gravatar image

la commence qui la suit directement, ça veut dire quoi ???

(06 Jul, 17:08) Bernard Bernard's gravatar image

J'imagine qu'Aurélien a voulu dire « la commande ».

(06 Jul, 17:10) denis ♦♦ denis's gravatar image

Pourvoir si le problème est propre à la bibliographie, il devrait suffire de créer un fichier .tex minimal ne comportant que \documentclass{article}, les packages \usepackage[T1]{fontenc}\usepackage[utf8]{inputenc}\usepackage[backend=biber]{biblatex}, la commande \addbibresource avec en argument obligatoire le nom du fichier .bib potentiellement problématique, la commande \nocite{*} pour que toutes les références qui figurent dans ce .bib soient citées, puis, entre \begin{document} et \end{document}, la commande \printbibliography.

(06 Jul, 17:20) denis ♦♦ denis's gravatar image

La compilation biber fait nettement apparaître des problèmes dans la bibliographie.

(06 Jul, 17:22) denis ♦♦ denis's gravatar image

Oui en effet, j'utilise Zotéro pour exporter ma bibliographie sauf que ma bibliothèque à un dossier thèse et que la dernière exportation à décidé d'exporter la bibliothèque plutot qu'uniquement le dossier c'est pour cela que je me suis retrouvé avec toutes ces erreurs corrigées depuis. Un ECM a été mis en question

(06 Jul, 18:09) AurélienCocq Aur%C3%A9lienCocq's gravatar image

L'ECM que j'ai publié n'a pas donné de resultats pendant les premières compilations et d'un coup cela fonctionne ... Par contre toujours rien pour mon fichier original. Serait ce un problème avec une référence de la bibliographie ?

(06 Jul, 18:18) AurélienCocq Aur%C3%A9lienCocq's gravatar image

@AurélienCocq Euh... ça n'est pas très clair. Un ECM construit à partir du fichier original et mettant en évidence le problème rencontré est nécessaire.

(06 Jul, 18:56) denis ♦♦ denis's gravatar image

J'ai legerement modifié l'ECM car j'ai remarqué dans mon document original que c'est quand j'ajoute cette reference bibliographique en particulier que le problème se pose ( reference defaye_les_2007-1)

(06 Jul, 22:42) AurélienCocq Aur%C3%A9lienCocq's gravatar image

@AurélienCocq Dans ce cas, ne mettre dans le fichier .bib que l'entrée posant problème (chose que je testerais d'ailleurs au préalable avec le document original).

(07 Jul, 00:22) denis ♦♦ denis's gravatar image

Le probleme persiste ... Mais je ne vois pas d'où peut provenir le probleme dans la référence ...

(07 Jul, 00:38) AurélienCocq Aur%C3%A9lienCocq's gravatar image

@touhami le problème persiste Cette référence fait parti de mon fichier bibliographique sans probleme mais c'est dès que je l'appelle dans mon developpement que sa bloque

(07 Jul, 01:41) AurélienCocq Aur%C3%A9lienCocq's gravatar image

@AurélienCocq Merci de essayer avec ce nouvel ECM

(07 Jul, 03:40) touhami touhami's gravatar image
Affichage de 5 parmi 13 Afficher 8 commentaire(s) en plus

Je n'ai eu aucun problème avec l'E.C.M. après que l'option [safeinputenc] a été virée. Elle est destinée, si j'ai bien compris, au cas où vous auriez dans votre bibliographie des caractères non couverts par utf8, mais pour lesquels TeX a une macro (exemple typique dans la documentation de biblatex: , traduit en TeX par \d{S}). Avec cette option, biber convertit les caractères non-ascii en macros TeX, et il semble qu'il ne le fasse pas toujours très bien.

Si vous n'en avez pas besoin, ce qui me paraît fort vraisemblable, vous supprimez l'option et obtenez un fichier .bbl en utf8, qui sera traité normalement:

Ouvrir dans l'éditeur Overleaf
 \documentclass[12pt,space=onehalf,fncychap=Bjornstrup]{yathesis}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}

\usepackage{csquotes}
\usepackage[backend=biber,sorting=none,style=numeric-comp]{biblatex}%,safeinputenc
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
   @article{defaye_les_2007-1,
    title = {Les Cyclodextrines en Pharmacie : Perspectives pour le Ciblage d’Actifs Thérapeutiques et le Contrôle d’Interactions Membranaires},
    volume = {65},
    issn = {0003-4509},
    url = {http://www.sciencedirect.com/science/article/pii/S0003450907900152},
    doi = {10.1016/S0003-4509(07)90015-2},
    timestamp = {2017-07-03T09:51:11Z},
    number = {1},
    journaltitle = {Annales Pharmaceutiques Françaises},
    shortjournal = {Annales Pharmaceutiques Françaises},
    author = {Defaye, J. and García Fernández, J.-M. and Ortiz Mellet, C.},
    date = {2007-01-01},
    pages = {33--49},
    keywords = {Applications en formulation,Ciblage,Cyclodextrines,Cyclodextrins,Effet héterocluster,Glycodendrimères,Glycodendrimers,Heterocluster effect,Interactions protéines-sucres,Lectines,Lectins,Multivalence,Multivalency,Nanoparticles,Nanoparticules,Neoglycoconjugates,Néoglycoconjugués,Pharmaceutical applications,Protein-carbohydrate interactions,Targeting},
    groups = {Biblio thèse}
}

\end{filecontents}
\addbibresource{\jobname.bib}
\usepackage[xindy,acronyms,symbols]{glossaries}

\begin{document}
neurotoxiques \autocite{defaye_les_2007-1}.

\selectlanguage{french}
\nocite{*}
\printbibliography
\makeatletter\@openrightfalse
\chapter{CV et productions scientifiques}
    blabla
    \@openrighttrue\makeatother

     \end{document}

alt text

Lien permanent

Publiée 07 Jul, 03:45

Bernard's gravatar image

Bernard
1.5k14
Taux d'acceptation : 28%

Modifiée 07 Jul, 04:37

Sauriez vous m'expliquer pourquoi est ce que ce problème est arrivé d'un coup ? Car cela fait plusieures semaines que je rédige ma thèse avec cette option chargée et il n'ya que depuis les dernières compilations de ce jour que cela a commencé a bugger

(07 Jul, 04:32) AurélienCocq Aur%C3%A9lienCocq's gravatar image

J'avoue que je n'en ai pas la moindre idée. Je ne sais pas comment fonctionne le convertisseur ascii. La seule explication possible à ma portée serait peut-être que cette référence qui pose problème n'a été introduite que récemment ?

(07 Jul, 15:40) Bernard Bernard's gravatar image

@AurélienCocq Le problème vient des apostrophes d’actifs et d’interactions. (Chez moi je tape d'actifs et d'interactions, ça ne pose pas du problème, mais c'une autre histoire). En effet avec l'option safeinputenc de biblatex, Biber convertit l'apostrophe en \textquoteright. Donc, et comme (la)TeX mange les espaces après une commande, le mot d’actifs devient d\textquoterightActifs et d’interactions devient d\textquoterightInteractions et le résultat est ! Undefined control sequence..

(07 Jul, 21:00) touhami touhami's gravatar image

@touhami ca c'est un bug de biber. Tu pourrais ouvrir un ticket à ce propos?

(15 Jul, 15:25) Maïeul Ma%C3%AFeul's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×47
×15
×4

Question posée : 06 Jul, 17:00

Question vue : 169 fois

Dernière mise à jour : 15 Jul, 15:25