J'ai installé la TeX Live 2022 en suivant la méthode indiquée par cette distribution.

J'ai mis à jour mon PATH :

$ echo $PATH
/usr/local/texlive/2022/bin/x86_64-linux:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
$ echo $MANPATH
/usr/local/texlive/2022/texmf/doc/man:
$ echo $INFOPATH
/usr/local/texlive/2022/texmf/doc/info:

Malheureusement, je ne réussis pas à utiliser tlmgr :

$ sudo tlmgr update --self -all

tlmgr: Local TeX Live (2021) is older than remote repository (2022).
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
See https://tug.org/texlive/upgrade.html for details.

Que se passe-t-il ?


Mise à jour

J'ai compilé ce petit fichier test :

\documentclass{article}
\begin{document}
test
\end{document}

Avec pdflatex :

$ pdflatex test1-tl-2022.tex 
This is pdfTeX, Version 3.141592653-2.6-1.40.23 (TeX Live 2021) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test1-tl-2022.tex
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2022-02-24>
(/usr/local/texlive/2022/texmf-dist/tex/latex/base/article.cls
Document Class: article 2021/10/04 v1.4n Standard LaTeX document class
(/usr/local/texlive/2022/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2022/texmf-dist/tex/latex/l3backend/l3backend-pdftex.def)
(./test1-tl-2022.aux) [1{/usr/local/texlive/2022/texmf-var/fonts/map/pdftex/upd
map/pdftex.map}] (./test1-tl-2022.aux) )</usr/local/texlive/2022/texmf-dist/fon
ts/type1/public/amsfonts/cm/cmr10.pfb>
Output written on test1-tl-2022.pdf (1 page, 11438 bytes).
Transcript written on test1-tl-2022.log.

Avec xelatex :

$ xelatex test1-tl-2022.tex 
This is XeTeX, Version 3.141592653-2.6-0.999993 (TeX Live 2021) (preloaded format=xelatex)
 restricted \write18 enabled.
entering extended mode
(./test1-tl-2022.tex
LaTeX2e <2021-11-15> patch level 1
L3 programming layer <2022-02-24>
(/usr/local/texlive/2022/texmf-dist/tex/latex/base/article.cls
Document Class: article 2021/10/04 v1.4n Standard LaTeX document class
(/usr/local/texlive/2022/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2022/texmf-dist/tex/latex/l3backend/l3backend-xetex.def
(|extractbb --version)) (./test1-tl-2022.aux)
(/usr/local/texlive/2022/texmf-dist/tex/latex/base/ts1cmr.fd) [1]
(./test1-tl-2022.aux) )
Output written on test1-tl-2022.pdf (1 page).
Transcript written on test1-tl-2022.log.

Avec lualatex :

$ lualatex test1-tl-2022.tex 
This is LuaHBTeX, Version 1.13.2 (TeX Live 2021) 
 restricted system commands enabled.
(./test1-tl-2022.tex
LaTeX2e <2021-11-15> patch level 1

luaotfload | load : FATAL ERROR
luaotfload | load :   × Failed to load "fontloader" module "basics-gen".
luaotfload | load :   × Error message:
luaotfload | load :     × "...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:301: system : no writeable cache path, quiting".

stack traceback:
    ...ive/2022/texmf-dist/tex/luatex/luaotfload/luaotfload.lua:200: in local 'load_fontloader_module'
    ...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:303: in upvalue 'init_main'
    ...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:590: in function 'luaotfload-init.lua'
    ...ive/2022/texmf-dist/tex/luatex/luaotfload/luaotfload.lua:322: in field 'main'
    [\directlua]:1: in main chunk

...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:301: system : no wr
iteable cache path, quiting
stack traceback:
    [C]: in function 'error'
    ...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:301: in function '
os.exit'
    ...ive/2022/texmf-dist/tex/luatex/luaotfload/luaotfload.lua:203: in local 'loa
d_fontloader_module'
    ...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:303: in upvalue 'i
nit_main'
    ...022/texmf-dist/tex/luatex/luaotfload/luaotfload-init.lua:590: in function '
luaotfload-init.lua'
    ...ive/2022/texmf-dist/tex/luatex/luaotfload/luaotfload.lua:322: in field 'mai
n'
    [\directlua]:1: in main chunk.
<everyjob> ...ring \\def\string \\encodingdefault{OT1}')end }
                                                  \let \f@encoding \encoding...

l.1 
  \documentclass{article}
?

Hem...

Posée 06 Avr, 08:42

Pathe's gravatar image

Pathe ♦♦
7.1k16167223
Taux d'acceptation : 58%

Modifiée 07 Avr, 18:48

La commande sudo /usr/local/texlive/2022/bin/x86_64-linux/tlmgr update --self -all fonctionne-t-elle ?

(06 Avr, 09:04) denis ♦♦ denis's gravatar image

Exactement la même réponse que sans sudo. Et je précise que je me suis bien déconnecté avant de faire la tentative, de manière à ce que les modifications du PATH soient prises en compte.

(06 Avr, 10:06) Pathe ♦♦ Pathe's gravatar image

Comme lualatex ne compile pas, j'ai mis à jour mon message principal.

(06 Avr, 13:18) Pathe ♦♦ Pathe's gravatar image

Que dit which pdflatex ?

(06 Avr, 13:25) samcarter samcarter's gravatar image

$ which pdflatex /usr/local/texlive/2022/bin/x86_64-linux/pdflatex

Les réponses pour xelatex et lualatex sont du même type : ces logiciels sont tous rangés dans /usr/local/texlive/2022/bin/x86_64-linux/.

(07 Avr, 07:22) Pathe ♦♦ Pathe's gravatar image

Que renvoient which tlmgr et /usr/local/texlive/2022/bin/x86_64-linux/tlmgr update --self -all ? Quant à lualatex, l'exemple ci-dessus contient « This is LuaHBTeX, Version 1.13.2 (TeX Live 2021) » ce qui laisse penser que which lualatex doit renvoyer /usr/local/texlive/2021/bin/x86_64-linux/lualatex plutôt que /usr/local/texlive/2022/bin/x86_64-linux/lualatex.

(07 Avr, 07:40) denis ♦♦ denis's gravatar image

$ which -a tlmgr /usr/local/texlive/2022/bin/x86_64-linux/tlmgr /usr/local/bin/tlmgr

$ /usr/local/texlive/2022/bin/x86_64-linux/tlmgr update --self -all tlmgr: Local TeX Live (2021) is older than remote repository (2022).

$ which -a lualatex /usr/local/texlive/2022/bin/x86_64-linux/lualatex /usr/local/bin/lualatex

$ tex --version TeX 3.141592653 (TeX Live 2021) kpathsea version 6.3.3

$ latex --version pdfTeX 3.141592653-2.6-1.40.23 (TeX Live 2021)

... mmh...

(07 Avr, 07:50) Pathe ♦♦ Pathe's gravatar image

$ sudo tlmgr option repository ctan tlmgr: setting default package repository to https://mirror.ctan.org/systems/texlive/tlnet tlmgr: updating /usr/local/texlive/2022/tlpkg/texlive.tlpdb

$ sudo tlmgr update --self -all tlmgr: Local TeX Live (2021) is older than remote repository (2022).

Je ne pige pas.

(07 Avr, 08:12) Pathe ♦♦ Pathe's gravatar image

Peut-être le miroir aléatoire utilisé n'est-il pas encore passé à la TL 2022. Que donne tlmgr update --self --all --repository=http://ctan.mines-albi.fr/systems/texlive/tlnet ?

(07 Avr, 08:16) denis ♦♦ denis's gravatar image

tlmgr update --self --all --repository=http://ctan.mines-albi.fr/systems/texlive/tlnet tlmgr: Local TeX Live (2021) is older than remote repository (2022).

Je crains que ce problème et le fait que lualatex ne compile pas ne soient liés. Je suis drôlement embêté : c'est fou comme je me suis attaché à lualatex !

(07 Avr, 08:47) Pathe ♦♦ Pathe's gravatar image

Que donne /usr/local/texlive/2022/bin/x86_64-linux/tlmgr update --self --all --repository=http://ctan.mines-albi.fr/systems/texlive/tlnet ? (Faire éventuellement précéder de sudo.)

(07 Avr, 09:17) denis ♦♦ denis's gravatar image

Chez moi :

$ tlmgr update --self --all --repository=http://ctan.mines-albi.fr/systems/texlive/tlnet tlmgr: package repository http://ctan.mines-albi.fr/systems/texlive/tlnet (verified) tlmgr: saving backups to /home/bitouze/texlive/2022/tlpkg/backups tlmgr: no self-updates for tlmgr available [ 1/76] [...]

(07 Avr, 09:19) denis ♦♦ denis's gravatar image

$ sudo tlmgr update --self --all --repository=http://ctan.mines-albi.fr/systems/texlive/tlnet tlmgr: Local TeX Live (2021) is older than remote repository (2022).

(07 Avr, 09:32) Pathe ♦♦ Pathe's gravatar image

Il me semble que l'installation n'a pas réussi. Les fichiers .log que vous avez posté indiquent:

"This is pdfTeX, Version 3.141592653-2.6-1.40.23 (TeX Live 2021)"

(07 Avr, 11:24) touhami touhami's gravatar image

Je pense également que c'est le cas. J'ai relancé une installation.

(07 Avr, 17:43) Pathe ♦♦ Pathe's gravatar image
Affichage de 5 parmi 15 Afficher 10 commentaire(s) en plus

Je pense avoir compris le problème : j'ai installé une TeX Live 2021 en croyant installer la version 2022. J'ai bien suivi la doc, mais je pense avoir tenté l'installation trop tôt : la propagation n'était peut-être pas complète, et j'aurais donc téléchargé la version de l'an dernier.

J'ai donc refait une installation à partir d'une image .iso, selon la méthode indiquée par Denis ; j'en ensuite vérifié que cette image était authentique :

$ sha512sum texlive2022.iso > hashtl2022.txt
$ diff -q hashtl2022.txt texlive2022.iso.sha512
$

La commande diff n'a rien renvoyé : l'empreinte numérique était donc conforme.

J'ai ensuite installé sans aucun problème. J'ai pu ensuite mettre à jour, compiler etc. Toutes les versions des logiciels indiquent bien leur appartenance à TeX Live 2022.

Lien permanent

Publiée 07 Avr, 18:23

Pathe's gravatar image

Pathe ♦♦
7.1k16167223
Taux d'acceptation : 58%

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×38
×25
×2

Question posée : 06 Avr, 08:42

Question vue : 536 fois

Dernière mise à jour : 07 Avr, 18:23