Je travaille avec TeX Live sous debian GNU/Linux. Aujourd'hui je tape dans mon terminal la commande texdoc tikz pour accéder à la documentation de TikZ... et quelle n'est pas ma surprise !

Ouvrir dans l'éditeur Overleaf
$ texdoc tikz
$ This tool has been deprecated, use 'gio open' instead.
See 'gio help open' for more info.

La documentation désirée s'est quand même ouverte, mais je m'interroge.

texdoc, deprecated, vraiment ? J'ai du mal à y croire.

Du coup je tape gio help open tikz, ça ne fonctionne pas, j'essaie d'autres trucs, comme gio open tikz... rien ne fonctionne.

Quelque linuxien pourrait-il m'éclairer sur la commande gio ?

Posée 20 Oct, 14:06

Pathe's gravatar image

Pathe ♦♦
2.6k11173
Taux d'acceptation : 60%

Modifiée 23 Oct, 17:35

texdoc. Il est fort probable un problème de système.

(20 Oct, 14:31) touhami touhami's gravatar image
1

Je suis sous une debian+texlive à jour (sid), et ça marche très bien: texdoc est dans texlive-base (ici version 2017.20171004-1, donc vieux de 10 jours). Bizarre pour gio, je ne vois pas le rapport (c'est dans libglib2.0-bin, rien à voir avec LaTeX).

D'où viens votre texdoc (which texdoc et dlocate texdoc devraient aider)? Votre système est-il à jour? Quel TeXLive?

Autre idée: ce n'est peut-être pas texdoc qui envoie l'erreur, mais le visionneur pdf qui est lancé automatiquement. Avec quoi votre pdf est ouvert?

(20 Oct, 18:31) the_alf the_alf's gravatar image

@the_alf locate texdoc plutôt que dlocate texdoc, non ?

(20 Oct, 23:04) denis ♦♦ denis's gravatar image
1

@Pathe voici une contribution d'un windowsien : bug, infos et infos ++

(20 Oct, 23:49) touhami touhami's gravatar image

$ which texdoc

/usr/bin/texdoc

(22 Oct, 18:26) Pathe ♦♦ Pathe's gravatar image

$ locate texdoc

$

(22 Oct, 18:27) Pathe ♦♦ Pathe's gravatar image
2

non, je pensais bien à dlocate. locate texdoc indique seulement où les fichier contenant le motif "texdoc" sont dans l'ensemble des systèmes de fichiers. dlocate texdoc indique seulement les fichiers installés par le système, et à quels package ils appartiennent. Par exemple pour moi locate bin/texdoc ,'indique texlive-base: /usr/bin/texdoc. Je peux donc savoir que l'exécutable que j'utilise est bien celui installé par la texlive de debian. À noter qu'il faut installer dlocate qui n'est peut être pas installé en standard mais est bien pratique.

(23 Oct, 11:09) the_alf the_alf's gravatar image

$ dlocate texdoc

texlive-lang-korean:

[...]

texlive-base: /etc/texmf/texdoctk

[...]

texlive-base: /usr/share/texlive/texmf-dist/scripts/texdoc

[...]

texlive-base: /usr/share/texlive/texmf-dist/scripts/texdoc/view.tlu

[...]

texlive-base: /usr/share/texlive/texmf-dist/texdoc

texlive-base: /usr/share/texlive/texmf-dist/texdoctk

[...]

texlive-base: /usr/bin/texdoc

texlive-base: /usr/bin/texdoctk

texlive-lang-greek: /usr/share/doc/texlive-doc/fonts/greektex/greektexdoc.pdf

[...]

texlive-lang-japanese: /usr/share/doc/texlive-doc/ptex/ptex-base/ptexdoc.tex.gz

(23 Oct, 14:39) Pathe ♦♦ Pathe's gravatar image

C'est donc bien le texdoc de debian qui est installé et lancé. Je dirais que cela ne doit pas venir de lui mais du visionneur pdf qui est lancé. Quelle est l'appli ouverte? Que donne texdoc -v tikz?

(23 Oct, 14:52) the_alf the_alf's gravatar image
1

Je n'avais pas vu le commentaire de touhami. Effectivement, c'est un bug de gnome, et non de LaTeX. Je suis sous KDE, et texdoc lance texdoc info: View command: (xdg-open "/usr/share/texlive/texmf-dist/doc/generic/pgf/pgfmanual.pdf") &. Apparemment, sous gnome, c'est gvfs-open qui est lancé. En tapant manuellement la commande précédente en remplaçant xdg-open par gvfs-open, j'obtiens votre symptôme: le message en deprecated, puis ouverture du fichier avec evince (le lecteur pdf de gnome). Pas de bug du coté TeXLive, donc, c'est gvfs-open et donc gnome le problème.

(23 Oct, 15:00) the_alf the_alf's gravatar image

$ texdoc -v tikz

texdoc info: View command: (xdg-open "/usr/share/texlive/texmf-dist/doc/generic/pgf/pgfmanual.pdf") & texdoc info: Setting environment LC_CTYPE to: fr_FR.UTF-8

$ This tool has been deprecated, use 'gio open' instead. See 'gio help open' for more info.

(evince:2258): Gtk-WARNING **: Allocating size to EvSidebar 0x564d86172690 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(23 Oct, 16:37) Pathe ♦♦ Pathe's gravatar image

OK, donc ne cherche pas, pas de problème pour texdoc, c'est le lancement du visionneur pdf sous gnome qui identifie un outil "deprecated" (obsolète? déconseillé?) quelque part entre xdg-open et evince.

Notes que le message d'erreur "deprecated" est même reçu après le retour du prompt shell ($), il est donc bien envoyé par la commande de visualisation terminée par un &, et non par texdoc lui même. Si tu tapes (xdg-open "/usr/share/texlive/texmf-dist/doc/generic/pgf/pgfmanual.pdf") &, tu vas probablement obtenir le même message.

(24 Oct, 12:12) the_alf the_alf's gravatar image

Pourquoi des parenthèses à cette commande ? Quoi qu'il en soit, vous aviez raison :

$ (xdg-open "/usr/share/texlive/texmf-dist/doc/generic/pgf/pgfmanual.pdf") &

[1] 1723

$ This tool has been deprecated, use 'gio open' instead.

See 'gio help open' for more info.

(evince:1730): Gtk-WARNING **: Allocating size to EvSidebar 0x55953563c690 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(24 Oct, 13:02) Pathe ♦♦ Pathe's gravatar image

@the_alf OK, c'est parce que ça n'existe pas sur mon Linux (basée sur rpm et pas apt) que j'ai cru à une erreur. Il y a je crois un équivalent à dlocate pour rpm mais je ne m'en souviens plus.

(24 Oct, 17:18) denis ♦♦ denis's gravatar image
Affichage de 5 parmi 14 Afficher 9 commentaire(s) en plus

Mon installation est récente et les commentaires avisés de the alf m'ont fait remarquer que je n'avais pas de dossier texmf jusqu'ici.

Suivant l'excellente réponse d'un certain Pathe, qui se demandait comment choisir son visualiseur de documentation, j'ai créé le fichier texmf/texdoc/texdoc.cnf.

Il contient seulement la ligne suivante :

Ouvrir dans l'éditeur Overleaf
viewer_pdf = evince %s &

et hop ! Le message d'erreur n'apparaît plus ! texdoc n'est plus fallacieusement annoncé comme étant deprecated !

Bon, ce n'est pas crucial, mais ne faudrait-il pas signaler cela à quelque instance développant gnome ou debian ?

Lien permanent

Publiée 24 Oct, 13:10

Pathe's gravatar image

Pathe ♦♦
2.6k11173
Taux d'acceptation : 60%

Modifiée 24 Oct, 13:13

Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×11
×7
×2
×1
×1

Question posée : 20 Oct, 14:06

Question vue : 208 fois

Dernière mise à jour : 24 Oct, 17:18