Je ne comprends pas ce qui se passe : j'utilise l'extension fmtcount, j'emploie la commande \FCloadlang{french}, comme indiqué dans sa documentation… et pourtant les nombres apparaissent en anglais !

Mais seulement chez moi, pas en compilant en ligne !

Quel paramètre fait donc échouer, sur ma TeXLive à jour, le choix de la langue ?

Voici donc un ECM, qui vraisemblablement compilera sans souci chez overleaf :

Ouvrir dans l'éditeur
\documentclass[12pt, a4paper, french]{scrartcl}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[fulloldstyle,largesmallcaps, light]{kpfonts}
\usepackage{fmtcount}
\FCloadlang{french}
\usepackage{babel}
\begin{document}
\Ordinalstringnum{1}
\Ordinalstringnum{2}
\Ordinalstringnum{3}
\end{document}

Posée 19 Déc '16, 15:45

Pathe's gravatar image

Pathe ♦♦
1.9k238
Taux d'acceptation : 62%

Modifiée 19 Déc '16, 15:49

En effet, ça compile bien sur overleaf... Que donnent les fichiers de sortie ? Des messages d'erreur ? Des alertes ?

(19 Déc '16, 16:08) jerome dequeker jerome%20dequeker's gravatar image

J'ai mis le log ici. Je ne vois rien de spécial.

Mon rendu est . J'en fais un copier-coller : First Second Third. Étrange.

(19 Déc '16, 18:20) Pathe ♦♦ Pathe's gravatar image
1

Dans ta question, tu dis que ta TeXLive est à jour. D'après ton fichier log, elle semble être de 2013, non ?

(19 Déc '16, 18:26) jerome dequeker jerome%20dequeker's gravatar image

Mon fichier .aux est .

Il contient un bel ensemble de \select@language{french}.

Je n'y comprends que pouic.

(19 Déc '16, 18:26) Pathe ♦♦ Pathe's gravatar image

Chez moi ça compile sans soucis (Package: fmtcount 2015/05/05 v3.01). La version de tes packages n'est pas donné dans le fichier log ??

Mon fichier .aux est exactement le même que le tien.

(19 Déc '16, 19:00) jerome dequeker jerome%20dequeker's gravatar image

Les liens ne fonctionnent pas pour moi.

Ajouter \IfFileExists{fc-french.def}{fichier trouvé}{fichier non trouvé} après \begin{document} pour voir si le fichier est bien installé.

(19 Déc '16, 21:37) touhami touhami's gravatar image

Oups ! J'ai fait trop vite ! En lieu et place du fichier log, j'ai copié-collé la sortie « console » de la compilation.

Je récapitule : le fichier .log, le vrai, est ici et les caractères apparaissant à l'écran lors de la compilation sont .

Et si je tape latex --version ? pdfTeX 3.1415926-2.5-1.40.14 (TeX Live 2013) !

Mea culpa maxima, je ne comprends pas ce qui se passe, j'ai dû louper la mise à jour quand je l'ai effectuée.

(19 Déc '16, 23:06) Pathe ♦♦ Pathe's gravatar image

@touhami : je ne comprends pas ce qui se passe pour vous lors de l'accès à ces fichiers. À titre d'essai, j'y ai même accédé, à plusieurs reprises et sans problème aucun, en utilisant l'anonymiseur tor, et donc avec des IP vraisemblablement exotiques.

(19 Déc '16, 23:09) Pathe ♦♦ Pathe's gravatar image
1

@Pathe avez vous essayé \IfFileExists{fc-french.def}{fichier trouvé}{fichier non trouvé}?

(20 Déc '16, 00:44) touhami touhami's gravatar image

Non, mais où donc devrais-je mettre cette commande ? Dans le préambule ?

Quo qu'il en soit, je me suis tiré d'affaire en compilant sur un autre ordinateur qui répond pdfTeX 3.14159265-2.6-1.40.15 (TeX Live 2015/dev/Debian) à la commande $ latex --version ; et ça fonctionne, les nombres apparaissent en français.

Je suis navré de polluer le forum avec un pépin qui, vraisemblablement, se révèle être plus dû à un souci d'installation bancale qu'à un code défectueux. Je suis prêt à effacer ce fil si nécessaire.

(20 Déc '16, 01:14) Pathe ♦♦ Pathe's gravatar image
Affichage de 5 parmi 10 Afficher 5 commentaire(s) en plus

Enfin je suis arrivé à reproduire le problème.

Pour régler ce problème il vous suffit de faire une mise à jour de fmtcount ou (ce qui est toujours recommandé) de charger fmtcount après babel.

Lien permanent

Publiée 22 Déc '16, 17:18

touhami's gravatar image

touhami
1.7k26
Taux d'acceptation : 44%

Modifiée 27 Déc '16, 15:20

denis's gravatar image

denis ♦♦
2.7k28

Chez moi ça marche bien même en mettant fmtcount avant babel. Une petite remarque cependant, qui sans doute n'a rien à voir avec le pb, j'ai mis utf8 en option à inputenc, et non utf8x.

(25 Déc '16, 13:06) vincentb1 vincentb1's gravatar image

@vincentb1 Attention ! Cette réponse était un commentaire plutôt qu'une réponse et a été convertie comme tel.

(25 Déc '16, 14:22) denis ♦♦ denis's gravatar image

@vincentb1 Ce problème ne se pose pas avec les dernières versions de fmtcount (la mise à jour est la première solution que j'ai proposé). Il est toutefois recommandé que fmtcount soit chargée après babel (pour éviter des problèmes des documents multilingues par exemple).

(25 Déc '16, 16:58) touhami touhami's gravatar image

En fait ça marche même tout aussi bien sans le \FCloadlang{french}, c'est parce que l'option french passée au \documentclass est distribuée à tous les paquetages, dont fmtcount.

Pour ceux qui sont curieux du mécanisme utilisé en interne de fmtcount : il y a un mécanisme qui met fmtcount soit dans un mode par défaut (sélectionné par l'appel de \@setdef@ultfmtcount), pour un formatage en anglais, soit dans un mode multilingue (sélectionné par l'appel de \@set@mulitling@fmtcount) pour un formatage dans la langue désignée par \languagename. La selection de ce mode est faite aux lignes 1963 à 2013. À la ligne 1979 on teste si une option de langue a été passé, et dans ce cas on se met en multilingue.

La sélection du langage par option a été développée par votre humble serviteur en juillet 2014, par contre je ne saurai dire quand est-ce que ça a été distribué au CTAN.

Lien permanent

Publiée 25 Déc '16, 16:48

vincentb1's gravatar image

vincentb1
992
Taux d'acceptation : 0%

@vincentb1 Il semble que vous avez publié votre réponse (commentaire) en même temps que j'étais en train de rédiger mon dernier commentaire (voir plus haut).

(26 Déc '16, 11:54) touhami touhami's gravatar image
Votre réponse
(dés)activer l'aperçu

Suivre cette question

Par courriel :

Une fois que vous serez enregistré, vous pourrez souscrire à n'importe quelle mise à jour ici

Par flux RSS :

Réponses

Réponses et commentaires

Bases de Markdown

  • *italique* ou _italique_
  • **gras** ou __gras__
  • Lien ::[texte](http://url.com/ "Titre ")
  • Image : ?![alt texte](/path/img.jpg "Titre ")
  • Liste numérotée : 1. Foo 2. Bar
  • Pour ajouter un passage à la ligne, ajoutez deux espaces à l'endroit où vous souhaitez que la ligne commence.
  • Les balises HTML de base sont également prises en charge.

Mots-clés de la question :

×10
×5
×3

Question posée : 19 Déc '16, 15:45

Question vue : 235 fois

Dernière mise à jour : 27 Déc '16, 15:20